大数相乘 java

Problem E: Product

Time Limit: 1 Sec  Memory Limit: 128 MB

Submit: 38  Solved: 25

[Submit][Status][Web Board]

Description

The problem is to multiply two integers X, Y. (0<=X,Y<10250)


 


Input

The input will consist of a set of pairs of lines. Each line in pair contains one multiplyer.


 


Output

For each input pair of lines the output line should consist one integer the product.


 


Sample Input

12

12

2

222222222222222222222222

Sample Output

144

444444444444444444444444

HINT

两个大数相乘,直到读到EOF(文件结尾)为止

1.首先,hasNext()是Scanner类的一个方法,判断是否有输入,有输入项,a .hasNext()为true,没有输入项,a.hasNext()为false。 这里就类似于c,c++里面的while(scanf("%d",&a)!=EOF)

2.大数的定义。

package sishuyan;
import java.math.BigInteger;
import java.util.Scanner;
public class Text {


public static void main(String[] args) {
  Scanner scan=new Scanner(System.in);
  while(scan.hasNext())
  {
  BigInteger a=scan.nextBigInteger();
  BigInteger b=scan.nextBigInteger();
  BigInteger c=a.multiply(b);
  System.out.println(c);
  }
}
}

你可能感兴趣的:(ACM,JAVA,大数)