Java sdut acm 2749 区域内点的个数

题目链接:点击打开链接

  区域内点的个数
Time Limit: 1000MS Memory Limit: 65536KB 
Submit Statistic Discuss 
Problem Description
X晚上睡不着的时候不喜欢玩手机,也不喜欢打游戏,他喜欢数星星。 
Input
 多组输入。 
每组先输入一个整数N(N <= 10000),接着输入两个点代表矩形的左下点B(x,y)和右上点T(x,y),然后输入N个(X,Y)代表N颗星星。问有多少颗星星在窗子内部,在窗边上的不计。
Output
 输出一个整数,代表有多少颗星星在窗子内部。 
Example Input
3
0 1
3 4
1 1
2 2
3 3Example Output
1Hint
  
Author
 zmx   


代码实现:

import java.util.Scanner;

class Point {
	int x;
	int y;

	public Point(int x, int y) {
		this.x = x;
		this.y = y;
	}

	public boolean Inornot(Point p1,Point p2) {
		boolean flag = false;
		if(x > p1.x&&x < p2.x&&y > p1.y&&y < p2.y)
			flag = true;
		return flag;
	}
}

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner input = new Scanner(System.in);
		while(input.hasNext()){
			int count = input.nextInt();
			Point[] points = new Point[count];
			int px1 = input.nextInt();
			int py1 = input.nextInt();
			int px2 = input.nextInt();
			int py2 = input.nextInt();
			Point p1 = new Point(px1,py1);
			Point p2 = new Point(px2,py2);
			int sum = 0;
			for(int i = 0;i < count;i++){
				points[i] = new Point(input.nextInt(), input.nextInt());
				if(points[i].Inornot(p1, p2))
					sum++;
			}
			System.out.println(sum);
		}

	}
}


你可能感兴趣的:(Java)