NAT-T_第1张图片
R3#show run | s nat
ip nat outside
ip nat inside
ip nat inside source list 1 interface Serial1/0 overload
ip nat inside source static udp 192.168.1.2 500 23.1.1.3 500 extendable
ip nat inside source static udp 192.168.1.2 4500 23.1.1.3 4500 extendable

R3#show run int s1/1
Building configuration...

Current configuration : 130 bytes
!
interface Serial1/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
serial restart-delay 0
end

R3#show run int s1/0
Building configuration...

Current configuration : 128 bytes
!
interface Serial1/0
ip address 23.1.1.3 255.255.255.0
ip nat outside
ip virtual-reassembly in
serial restart-delay 0
end

R5#show run | s ospf
ip ospf network point-to-multipoint
router ospf 1
router-id 5.5.5.5
network 5.5.5.5 0.0.0.0 area 0
network 10.1.1.3 0.0.0.0 area 0
R5#show run inter s1/0
Building configuration...

Current configuration : 89 bytes
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.0
serial restart-delay 0
end
R5#show run int tunnel 0
Building configuration...

Current configuration : 378 bytes
!
interface Tunnel0
ip address 10.1.1.3 255.255.255.0
no ip redirects
ip nhrp authentication cisco123
ip nhrp map 10.1.1.1 12.1.1.1
ip nhrp map multicast 12.1.1.1
ip nhrp network-id 100
ip nhrp nhs 10.1.1.1
ip nhrp shortcut
ip ospf network point-to-multipoint
tunnel source Serial1/0
tunnel mode gre multipoint
tunnel key 100
tunnel protection ipsec profile k
end

R5#show run | s cry
R5#show run | s cry
no service password-encryption
crypto isakmp policy 10
hash md5
authentication pre-share
group 2
crypto isakmp key 6 cisco address 0.0.0.0
crypto ipsec transform-set k esp-aes esp-sha-hmac
mode transport
crypto ipsec profile k
set transform-set k

结果
R3#show ip nat translations
Pro Inside global Inside local Outside local Outside global
udp 23.1.1.3:500 192.168.1.2:500 --- ---
udp 23.1.1.3:4500 192.168.1.2:4500 12.1.1.1:4500 12.1.1.1:4500
udp 23.1.1.3:4500 192.168.1.2:4500 --- ---
R5#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!