三层交换机静态路由&VLAN配置实例(华为)

三层交换机静态路由&VLAN配置实例(华为)_第1张图片

 

/*telnet配置请回顾之前的博客*/

实验目的:学会静态路由的原理与配置

                 三层交换机的配制

LSW1

vlan batch 2 to 3 12           

//2 和 3 为PC1和PC2 的VLAN  12为LSW1与LSW2的直连VLAN

interface Vlanif2                             //此为PC1的网关

 ip address 192.168.1.254 255.255.255.0

interface Vlanif12                           //此为交换机1和2的直连路由

 ip address 1.1.1.1 255.255.255.252

interface GigabitEthernet0/0/1

 port link-type access

 port default vlan 2

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2 5 12

ip route-static 3.3.3.2 255.255.255.252 1.1.1.2

//交换机静态路由,为了实现LSW1与LSW4互通 其中3.3.3.2为目的地址 1.1.1.2为下一条地址。因为我们只知道到1.1.1.2的路线。所以需要往1.1.1.2上跳过去

ip route-static 3.3.3.2 255.255.255.252 1.1.1.2

 

LSW2

vlan batch 12 23          23为LSW2与LSW3的直连路由

interface Vlanif12

 ip address 1.1.1.2 255.255.255.252

interface Vlanif23

 ip address 2.2.2.1 255.255.255.252

interface GigabitEthernet0/0/2

 port link-type trunk

 port trunk allow-pass vlan 2 5 12

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 5 23

ip route-static 3.3.3.2 255.255.255.252 2.2.2.2

//此时发现LSW2上也没有3.3.3.2的路由,继下一跳为 2.2.2.2  发现 2.2.2.2 的路由表里有去往LSW4的路由,那么此时从1.1.1.1到3.3.3.2的单项静态路由已经完毕

 

//还需要进行下一跳

LSW3

#

vlan batch 23 34

#

interface Vlanif23

 ip address 2.2.2.2 255.255.255.252

#

interface Vlanif34

 ip address 3.3.3.1 255.255.255.252

 

#

interface GigabitEthernet0/0/3

 port link-type trunk

 port trunk allow-pass vlan 2 5 23

#

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 2 5 34

#

 ip route-static 1.1.1.1 30   2.2.2.1

/跳到LSW3后发现没有到1.1.1.1的路由那么就向LSW2上的2.2.2.1上跳发现2.2.2.1上有到1.1.1.1的路由那么此时的回城路由就已经指玩*/

LSW4

vlan batch 3 5 34

#

interface Vlanif5

 ip address 172.16.1.254 255.255.255.0

#

interface Vlanif34

 ip address 3.3.3.2 255.255.255.252

interface GigabitEthernet0/0/4

 port link-type trunk

 port trunk allow-pass vlan 2 5 34

#

interface GigabitEthernet0/0/5

 port link-type access

 port default vlan 5

//LSW4收到LSW1的单项路由后还需要向LSW1进行回复此时就需要回指一条静态路由,此时的目的地址为LSW1 的地址为1.1.1.1下一跳就变为 3.3.3.1

ip route-static 1.1.1.1 255.255.255.252 3.3.3.1

 

 

 

你可能感兴趣的:(华为基础配置)