CCNP帧中继拓扑图
2.实验设备:5台GNS3 3600路由器(R1 R2 R3R4 R5)中间的R5模拟帧中继交换机,通过S1/0、S1/1、S1/2 、S1/3 串行连接R1/ R2/ R3/ R4 .
实验要求
配置帧中继网络的静态映射及点到点子接口和点到多点的帧中继网络。
实验配置:
配置帧中继交换机:
--------------------------------------------R5帧中继-----------------------------------------------------------------------
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
(config)#frame-relay switching //将路由器模拟为帧中继交换机
archive
logconfig
hidekeys
!
!
!
!
ip tcp synwait-time 5
(config)#inter S1/0 //进入S1/0接口
(config-if)#no shout //开启接口
(config-if)#encapsulation frame-relayIETF //为接口封装帧中继
(config-if)#serial restart-delay 0
(config-if)#frame-relay lmi-type ansi
(config-if)#frame-relay local-dlci 103
(config-if)#frame intf-type dce //声明帧中继接口电缆类
(config-if)#frame-relay route 102 interfaceSerial1/1 201
//配置帧中继路由,102 为进入接口的 DLCI 号,从 S1/1 的 DLCI 201 发出去。
(config-if)#frame-relay route 103 interfaceSerial1/2 301
//配置帧中继路由,103 为进入接口的 DLCI 号,从 S1/2 的 DLCI 301 发出去。
(config-if)#frame-relay route 104 interfaceSerial1/3 401
//配置帧中继路由,104 为进入接口的 DLCI 号,从 S1/3 的 DLCI 401 发出去。
interface S1/1 //进入S1/1接口
noshout //开启接口
encapsulation frame-relay IETF //为接口封装帧中继
serial restart-delay 0
frame-relay lmi-type ansi
frame-relay intf-type dce //声明帧中继接口电缆类
frame-relay route 201 interface Serial1/0 102
//配置帧中继路由,201为进入接口的 DLCI 号,从 S1/0 的 DLCI 102 发出去。
showframe-relay route //查看帧中继交换机上的路由
!
interface Serial1/2
noshout
encapsulation frame-relay IETF
serialrestart-delay 0
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 301 interface Serial1/0 103
//配置帧中继路由,301为进入接口的 DLCI 号,从 S1/0 的 DLCI 103 发出去。
!
interface S1/3
noshout
encapsulation frame-relay IETF
serial restart-delay 0
frame-relaylmi-type ansi
frame-relay intf-type dce
frame-relay route 401 interface Serial1/0 104
//配置帧中继路由,401为进入接口的 DLCI 号,从 S1/0 的 DLCI 104 发出去。
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
点到点帧中继的静态映射:
------------------------------------------------R1路由器----------------------------------------------------------------
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
logconfig
hidekeys
!
ip tcp synwait-time 5
!
interface Lo0
ipaddress 1.1.1.1 255.255.255.0
!
interface S1/0
noshout
encapsulation frame-relay IETF
serial restart-delay 0
noframe-relay inverse-arp //关闭反向 ARP 解析(默认打开)
frame-relay lmi-type ansi
!
interface S1/0.12 point-to-point
ipaddress 11.11.11.1 255.255.255.252
snmptrap link-status
frame-relay interface-dlci 102
!
interface S1/0.134 multipoint
ipaddress 12.12.12.1 255.255.255.0
noip split-horizon
snmptrap link-status
frame-relay map ip 12.12.12.2 103broadcast
//手动配置一条到 R3 的帧中继映射,使用目的 IP 及本端 DLCI。
frame-relay map ip 12.12.12.3 104 broadcast
//手动配置一条到 R4的帧中继映射,使用目的IP 及本端 DLCI。
!
router rip//配置版本2的RIP路由协议
version 2
net1.0.0.0
net11.0.0.0
net12.0.0.0
noauto-summary//关闭自动汇总
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
sh frame-relay map
//解析到 dynamic(动态)的 DLCI 映射,活动状态为static(关闭)
------------------R2路由器--------------
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
logconfig
hidekeys
!
ip tcp synwait-time 5
!
interface Lo0
ipaddress 2.2.2.2 255.255.255.0
!
interface S1/1
ipaddress 11.11.11.2 255.255.255.252
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay map ip 11.11.11.1 201 broadcast
//手动配置一条到 R1 的帧中继映射,使用目的 IP 及本端 DLCI。
frame-relay lmi-type ansi
!
router rip//配置版本2的RIP路由协议
version 2
net2.0.0.0
net11.0.0.0
noauto-summary
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
--------------R3路由器--------------
配置使用子接口的帧中继网络:
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
logconfig
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
interface Lo0
ipaddress 3.3.3.3 255.255.255.0
!
interface S1/2
ipaddress 12.12.12.2 255.255.255.0
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay map ip 12.12.12.1 301 broadcast
//手动配置一条到 R1 的帧中继映射,使用目的 IP 及本端 DLCI。
frame-relay map ip 12.12.12.3 301 broadcast
//手动配置一条到 R4 的帧中继映射,使用目的 IP 及本端 DLCI。
noframe-relay inverse-arp //关闭反向 ARP 解析(默认打开)
frame-relay lmi-type ansi
!
router rip//配置版本2的RIP路由协议
version 2
net3.0.0.0
net12.0.0.0
noauto-summary//关闭自动汇总
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
#sh frame-relay map
#sh frame-relay pvc //显示路由器所定义帧中继PVC 的统
------------------------------------------------------------R4路由器-------------------------------------------------------
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
ip cef
no ip domain lookup
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
archive
logconfig
hidekeys
!
ip tcp synwait-time 5
!
interface Lo0
ipaddress 4.4.4.4 255.255.255.0
!
interface S1/3
ipaddress 12.12.12.3 255.255.255.0
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay map ip 12.12.12.1 401 broadcast
//手动配置一条到 R1 的帧中继映射,使用目的 IP 及本端 DLCI。
frame-relay map ip 12.12.12.2 401 broadcast
//手动配置一条到 R3 的帧中继映射,使用目的IP 及本端 DLCI。
noframe-relay inverse-arp //关闭反向 ARP 解析(默认打开)
frame-relay lmi-type ansi
!
router rip //配置版本2的RIP路由协议
version 2
net4.0.0.0
net12.0.0.0
noauto-summary//关闭自动汇总
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
#sh frame-relay map
#sh frame-relay pvc //显示路由器所定义帧中继PVC 的统
#sh iprouter //查看所有路由器的路由表
测试互联互通:
实验总结:注意帧中继的不同配置情况,每个接口必须都正确封装帧中继并启用端口,手
动配置时必须关掉反向 ARP 解析并清除动态的映射;当存在不同子网的连接时必须配置子
接口,子接口需要指定连接类型以及子接口的 DLCI 号。PVC 的状态必须全部为活动时才
能进行帧中继映射。
完
吴迪
2017.11.2