hdoj 1241 Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16542    Accepted Submission(s): 9500


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

 

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
 
Sample Output
0
1
2
2
 
简单的搜索题  和南阳的 水池数目差不多  只不过增加了 四个方向的搜索
#include<stdio.h>
#include<string.h>
#define MAX 110
char s[MAX][MAX];
int n,m;
void dfs(int x,int y)
{
	if(0<=x&&x<n&&0<=y&&y<m&&s[x][y]=='@')
	{
		s[x][y]='*';//将判断过的位置标记 
		dfs(x-1,y);//搜索上边 
		dfs(x+1,y);//搜索下边 
		dfs(x,y-1);//搜索左边 
		dfs(x,y+1);//搜索右边 
		dfs(x-1,y-1);//搜索左上 
		dfs(x-1,y+1);//搜索右上 
		dfs(x+1,y-1);//搜索左下 
		dfs(x+1,y+1);//搜索右下 
	}
}
int main()
{
	int j,i,sum,t,k;
	while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
	{
		for(i=0;i<n;i++)
		{
			scanf("%s",s[i]);
		}
		sum=0;
		for(i=0;i<=n;i++)
		{
			for(j=0;j<m;j++)
			{
				if(s[i][j]=='@')
				{
					dfs(i,j);
					sum++;
				}
			}
		}
		printf("%d\n",sum);//搜索次数就为油田数目 
	}
	return 0;
} 

  

你可能感兴趣的:(OS)