这个TOP图有一点小问题,在R6和R7的两个网段是150.150.0.0,这样会引起冲突,于是我将R7的150.150.0.0改成了140.140.0.0这个网段
下面来看看配置吧:
配置我只复制了其中的一部分。将没有配置的那些接口都删除了,只显示所有配置的东西!
R1
:
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Serial1/1
ip address 192.168.3.2 255.255.255.0
serial restart-delay 0
!
router eigrp 100
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
ip address 192.168.2.1 255.255.255.0
!
interface Serial1/1
ip address 192.168.3.2 255.255.255.0
serial restart-delay 0
!
router eigrp 100
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
-----------------------------------------------------------------------------------
R2
的配置:
interface Serial1/0
ip address 192.168.3.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 10.0.0 .2 255.255.255.0
ip router isis
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay 封装帧中继
no frame-relay inverse-arp
!
interface Serial1/2.1 point-to-point 子接口的点到点
ip address 10.0.1.2 255.255.255.0
ip router isis 在接口上激活IS-IS,使这个接口的IP子网能够被发布
frame-relay interface-dlci 203 帧中继的映射
!
router eigrp 100
redistribute isis level-1-2 metric 10000 100 255 1 1500 将IS-IS中的路由重发布进
network 192.168.3.0 EIGRP 中
no auto-summary
!
router isis 启动IS-IS
net 49.0001.0000. 0000.0002.00 49.0001表示区域号。0000.0000.0002表示系统ID
summary-address 192.168.0.0 255.255.0.0 将eigrp中的路由进行汇总
redistribute eigrp 100 将eigrp中的路由重发布进ISIS中
!
将IS-IS应用在帧中继的点到点的网络中,每个与帧中继相连的接口都必须使用子接口来做,不像ospf的其他的不必做在子接口下,这个如果没有做在子接口下的话,那么他们的邻居关系就建立不起来!
-----------------------------------------------------------------------------------
R3
的配置:
interface Serial1/1
ip address 10.0.3 .1 255.255.255.252
ip router isis 在接口上激活IS-IS,使这个接口的IP子网能够被发布
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial1/2.1 point-to-point
ip address 10.0.1.1 255.255.255.0
ip router isis 帧为继的设置
frame-relay interface-dlci 302
!
interface Serial1/2.2 point-to-point
ip address 10.0.2.1 255.255.255.0
ip router isis
frame-relay interface-dlci 304
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router isis 启动isis路由
net 49.0001.0000. 0000.0003.00
!
ip address 10.0.3 .1 255.255.255.252
ip router isis 在接口上激活IS-IS,使这个接口的IP子网能够被发布
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial1/2.1 point-to-point
ip address 10.0.1.1 255.255.255.0
ip router isis 帧为继的设置
frame-relay interface-dlci 302
!
interface Serial1/2.2 point-to-point
ip address 10.0.2.1 255.255.255.0
ip router isis
frame-relay interface-dlci 304
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router isis 启动isis路由
net 49.0001.0000. 0000.0003.00
!
-----------------------------------------------------------------------------------
R4
的配置:
interface Serial1/1
ip address 10.0.4 .1 255.255.255.0
ip router isis
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
! 帧中继的设置
interface Serial1/2.1 point-to-point
ip address 10.0.2.2 255.255.255.0
ip router isis
frame-relay interface-dlci 403
!
router isis
net 49.0004.0000. 0000.0004.00
summary-address 172.16.0.0 255.255.0.0 对172.16.0.0进行汇总
!
ip address 10.0.4 .1 255.255.255.0
ip router isis
serial restart-delay 0
!
interface Serial1/2
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
! 帧中继的设置
interface Serial1/2.1 point-to-point
ip address 10.0.2.2 255.255.255.0
ip router isis
frame-relay interface-dlci 403
!
router isis
net 49.0004.0000. 0000.0004.00
summary-address 172.16.0.0 255.255.0.0 对172.16.0.0进行汇总
!
-----------------------------------------------------------------------------------
R5
的配置:
interface Serial1/0
ip address 10.0.4 .2 255.255.255.252
ip router isis
serial restart-delay 0
no fair-queue
!
interface Serial1/1
ip address 10.0.4.5 255.255.255.252
ip router isis
serial restart-delay 0
!
router isis
net 49.0004.0000. 0000.0005.00
is-type level-1 将R5设置成level-1的类型
!
ip address 10.0.4 .2 255.255.255.252
ip router isis
serial restart-delay 0
no fair-queue
!
interface Serial1/1
ip address 10.0.4.5 255.255.255.252
ip router isis
serial restart-delay 0
!
router isis
net 49.0004.0000. 0000.0005.00
is-type level-1 将R5设置成level-1的类型
!
-----------------------------------------------------------------------------------
R6
的配置:
interface Loopback0
ip address 150.150.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 150.150.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 150.150.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 150.150.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 150.150.4.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 10.0.3 .5 255.255.255.252
ip router isis
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.3.2 255.255.255.252
ip router isis
serial restart-delay 0
isis priority 127
!
ip address 150.150.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 150.150.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 150.150.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 150.150.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 150.150.4.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 10.0.3 .5 255.255.255.252
ip router isis
duplex auto
speed auto
!
interface Serial1/0
ip address 10.0.3.2 255.255.255.252
ip router isis
serial restart-delay 0
isis priority 127
!
router isis
net 49.0003.0000.0000.0006.00
summary-address 150.150.0.0 255.255.0.0 level-1-2 将150.150.0.0进行汇总
net 49.0003.0000.0000.0006.00
summary-address 150.150.0.0 255.255.0.0 level-1-2 将150.150.0.0进行汇总
成level-1-2的类型
summary-address 140.140.0.0 255.255.0.0 将140.140.0.0汇总默认是level-2的类型
!
summary-address 140.140.0.0 255.255.0.0 将140.140.0.0汇总默认是level-2的类型
!
-----------------------------------------------------------------------------------
R7
的配置:
interface Loopback0
ip address 140.140.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 140.140.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 140.140.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 140.140.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 140.140.4.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 10.0.3 .6 255.255.255.252
ip router isis
duplex auto
speed auto
!
router isis
net 49.0003.0000. 0000.0007.00
is-type level-1 设置成level-1的类型
!
ip address 140.140.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 140.140.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 140.140.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 140.140.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 140.140.4.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 10.0.3 .6 255.255.255.252
ip router isis
duplex auto
speed auto
!
router isis
net 49.0003.0000. 0000.0007.00
is-type level-1 设置成level-1的类型
!
-----------------------------------------------------------------------------------
R8
的配置:
interface Loopback0
ip address 130.130.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 130.130.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 130.130.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 130.130.3.1 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 10.0.0 .1 255.255.255.0
ip router isis
serial restart-delay 0
!
router isis
net 49.0002.0000. 0000.0008.00
is-type level-2-only
summary-address 130.130.0.0 255.255.0.0
!
ip address 130.130.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 130.130.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 130.130.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 130.130.3.1 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 10.0.0 .1 255.255.255.0
ip router isis
serial restart-delay 0
!
router isis
net 49.0002.0000. 0000.0008.00
is-type level-2-only
summary-address 130.130.0.0 255.255.0.0
!
-----------------------------------------------------------------------------------
R9
的配置:
interface Loopback0
ip address 172.16.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 172.16.4.1 255.255.255.0
ip router isis
!
interface Loopback5
ip address 172.16.5.1 255.255.255.0
ip router isis
!
interface Loopback6
ip address 172.16.6.1 255.255.255.0
ip router isis
!
interface Loopback7
ip address 172.16.7.1 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 10.0.4 .6 255.255.255.252
ip router isis
serial restart-delay 0
!
router isis
net 49.0004.0000. 0000.0009.00
is-type level-1
summary-address 172.16.0.0 255.255.0.0
!
ip address 172.16.0.1 255.255.255.0
ip router isis
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
ip router isis
!
interface Loopback2
ip address 172.16.2.1 255.255.255.0
ip router isis
!
interface Loopback3
ip address 172.16.3.1 255.255.255.0
ip router isis
!
interface Loopback4
ip address 172.16.4.1 255.255.255.0
ip router isis
!
interface Loopback5
ip address 172.16.5.1 255.255.255.0
ip router isis
!
interface Loopback6
ip address 172.16.6.1 255.255.255.0
ip router isis
!
interface Loopback7
ip address 172.16.7.1 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 10.0.4 .6 255.255.255.252
ip router isis
serial restart-delay 0
!
router isis
net 49.0004.0000. 0000.0009.00
is-type level-1
summary-address 172.16.0.0 255.255.0.0
!
-----------------------------------------------------------------------------------
以上就是实验的配置,下面看看sh ip route 出来的路由条目吧!
R1
的:
D EX 140.140.0.0/16 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 172.16.0.0/16 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
10.0.0 .0/8 is variably subnetted, 6 subnets, 2 masks
D EX 10.0.2.0/24 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.3.0/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.4/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.3.4/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.0/24 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.0/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 130.130.0.0/16 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/ 1
C 192.168.0.0/24 is directly connected, Loopback 0
C 192.168.1.0/24 is directly connected, Loopback 1
C 192.168.2.0/24 is directly connected, Loopback 2
C 192.168.3.0/24 is directly connected, Serial1/1
D EX 150.150.0.0/16 [170/2195456] via 192.168.3.1, 00:49:18, Serial1/1
D EX 172.16.0.0/16 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
10.0.0 .0/8 is variably subnetted, 6 subnets, 2 masks
D EX 10.0.2.0/24 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.3.0/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.4/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.3.4/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.0/24 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 10.0.4.0/30 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/1
D EX 130.130.0.0/16 [170/2195456] via 192.168.3.1, 00:48:52, Serial1/ 1
C 192.168.0.0/24 is directly connected, Loopback 0
C 192.168.1.0/24 is directly connected, Loopback 1
C 192.168.2.0/24 is directly connected, Loopback 2
C 192.168.3.0/24 is directly connected, Serial1/1
D EX 150.150.0.0/16 [170/2195456] via 192.168.3.1, 00:49:18, Serial1/1
-----------------------------------------------------------------------------------
R2
的:
Gateway of last resort is not set
i L2 140.140.0.0/16 [115/40] vi a 10.0.1 .1, Serial1/2.1
i L2 172.16.0.0/16 [115/50] vi a 10.0.1 .1, Serial1/2.1
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L1 10.0.2.0/24 [115/20] vi a 10.0.1 .1, Serial1/2.1
i L1 10.0.3.0/30 [115/20] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.4/30 [115/40] vi a 10.0.1 .1, Serial1/ 2.1
C 10.0.0.0/24 is directly connected, Serial1/ 1
C 10.0.1.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.4/30 [115/30] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.0/30 [115/40] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.0/24 [115/30] vi a 10.0.1 .1, Serial1/2.1
i L2 130.130.0.0/16 [115/20] vi a 10.0.0 .1, Serial1/1
D 192.168.0.0/24 [90/2297856] via 192.168.3.2, 02:18:59, Serial1/0
D 192.168.1.0/24 [90/2297856] via 192.168.3.2, 02:19:39, Serial1/0
D 192.168.2.0/24 [90/2297856] via 192.168.3.2, 02:19:39, Serial1/ 0
C 192.168.3.0/24 is directly connected, Serial1/0
i L2 150.150.0.0/16 [115/30] vi a 10.0.1 .1, Serial1/2.1
i su 192.168.0.0/16 [115/0] via 0.0.0.0, Null0
i L2 172.16.0.0/16 [115/50] vi a 10.0.1 .1, Serial1/2.1
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L1 10.0.2.0/24 [115/20] vi a 10.0.1 .1, Serial1/2.1
i L1 10.0.3.0/30 [115/20] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.4/30 [115/40] vi a 10.0.1 .1, Serial1/ 2.1
C 10.0.0.0/24 is directly connected, Serial1/ 1
C 10.0.1.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.4/30 [115/30] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.0/30 [115/40] vi a 10.0.1 .1, Serial1/2.1
i L2 10.0.4.0/24 [115/30] vi a 10.0.1 .1, Serial1/2.1
i L2 130.130.0.0/16 [115/20] vi a 10.0.0 .1, Serial1/1
D 192.168.0.0/24 [90/2297856] via 192.168.3.2, 02:18:59, Serial1/0
D 192.168.1.0/24 [90/2297856] via 192.168.3.2, 02:19:39, Serial1/0
D 192.168.2.0/24 [90/2297856] via 192.168.3.2, 02:19:39, Serial1/ 0
C 192.168.3.0/24 is directly connected, Serial1/0
i L2 150.150.0.0/16 [115/30] vi a 10.0.1 .1, Serial1/2.1
i su 192.168.0.0/16 [115/0] via 0.0.0.0, Null0
-----------------------------------------------------------------------------------
R3
的:
Gateway of last resort is not set
i L2 140.140.0.0/16 [115/30] vi a 10.0.3 .2, Serial1/1
i L2 172.16.0.0/16 [115/40] vi a 10.0.2 .2, Serial1/2.2
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.0.2.0/24 is directly connected, Serial1/ 2.2
C 10.0.3.0/30 is directly connected, Serial1/1
i L2 10.0.4.4/30 [115/30] vi a 10.0.2 .2, Serial1/2.2
i L1 10.0.0.0/24 [115/20] vi a 10.0.1 .2, Serial1/ 2.1
C 10.0.1.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.4/30 [115/20] vi a 10.0.3 .2, Serial1/1
i L2 10.0.4.0/30 [115/30] vi a 10.0.2 .2, Serial1/2.2
i L2 10.0.4.0/24 [115/20] vi a 10.0.2 .2, Serial1/2.2
i L2 130.130.0.0/16 [115/30] vi a 10.0.1 .2, Serial1/2.1
i L2 150.150.0.0/16 [115/20] vi a 10.0.3 .2, Serial1/1
i L2 192.168.0.0/16 [115/10] vi a 10.0.1 .2, Serial1/2.1
i L2 172.16.0.0/16 [115/40] vi a 10.0.2 .2, Serial1/2.2
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.0.2.0/24 is directly connected, Serial1/ 2.2
C 10.0.3.0/30 is directly connected, Serial1/1
i L2 10.0.4.4/30 [115/30] vi a 10.0.2 .2, Serial1/2.2
i L1 10.0.0.0/24 [115/20] vi a 10.0.1 .2, Serial1/ 2.1
C 10.0.1.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.4/30 [115/20] vi a 10.0.3 .2, Serial1/1
i L2 10.0.4.0/30 [115/30] vi a 10.0.2 .2, Serial1/2.2
i L2 10.0.4.0/24 [115/20] vi a 10.0.2 .2, Serial1/2.2
i L2 130.130.0.0/16 [115/30] vi a 10.0.1 .2, Serial1/2.1
i L2 150.150.0.0/16 [115/20] vi a 10.0.3 .2, Serial1/1
i L2 192.168.0.0/16 [115/10] vi a 10.0.1 .2, Serial1/2.1
-----------------------------------------------------------------------------------
R4
的:
Gateway of last resort is not set
i L2 140.140.0.0/16 [115/40] vi a 10.0.2 .1, Serial1/2.1
172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
i L1 172.16.4.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.5.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.6.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.7.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.0.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i su 172.16.0.0/16 [115/30] via 0.0.0.0, Null0
i L1 172.16.1.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.2.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.3.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.0.2.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.0/30 [115/20] vi a 10.0.2 .1, Serial1/2.1
i L1 10.0.4.4/30 [115/20] vi a 10.0.4 .2, Serial1/1
i L2 10.0.0.0/24 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L2 10.0.1.0/24 [115/20] vi a 10.0.2 .1, Serial1/2.1
i L2 10.0.3.4/30 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L1 10.0.4.0/30 [115/20] vi a 10.0.4 .2, Serial1/ 1
C 10.0.4.0/24 is directly connected, Serial1/1
i L2 130.130.0.0/16 [115/40] vi a 10.0.2 .1, Serial1/2.1
i L2 150.150.0.0/16 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L2 192.168.0.0/16 [115/20] vi a 10.0.2 .1, Serial1/2.1
172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
i L1 172.16.4.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.5.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.6.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.7.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.0.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i su 172.16.0.0/16 [115/30] via 0.0.0.0, Null0
i L1 172.16.1.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.2.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
i L1 172.16.3.0/24 [115/30] vi a 10.0.4 .2, Serial1/1
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.0.2.0/24 is directly connected, Serial1/2.1
i L2 10.0.3.0/30 [115/20] vi a 10.0.2 .1, Serial1/2.1
i L1 10.0.4.4/30 [115/20] vi a 10.0.4 .2, Serial1/1
i L2 10.0.0.0/24 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L2 10.0.1.0/24 [115/20] vi a 10.0.2 .1, Serial1/2.1
i L2 10.0.3.4/30 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L1 10.0.4.0/30 [115/20] vi a 10.0.4 .2, Serial1/ 1
C 10.0.4.0/24 is directly connected, Serial1/1
i L2 130.130.0.0/16 [115/40] vi a 10.0.2 .1, Serial1/2.1
i L2 150.150.0.0/16 [115/30] vi a 10.0.2 .1, Serial1/2.1
i L2 192.168.0.0/16 [115/20] vi a 10.0.2 .1, Serial1/2.1
-----------------------------------------------------------------------------------
R5
的:
Gateway of last resort is 10.0.4 .1 to network 0.0.0.0
172.16.0.0/24 is subnetted, 8 subnets
i L1 172.16.4.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.5.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.6.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.7.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.0.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.1.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.2.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.3.0 [115/20] vi a 10.0.4 .6, Serial1/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
i L1 10.0.2.0/24 [115/20] vi a 10.0.4 .1, Serial1/ 0
C 10.0.4.4/30 is directly connected, Serial1/ 1
C 10.0.4.0/30 is directly connected, Serial1/0
i L1 10.0.4.0/24 [115/20] vi a 10.0.4 .1, Serial1/0
i*L1 0.0.0.0/0 [115/10] vi a 10.0.4 .1, Serial1/0
i L1 172.16.4.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.5.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.6.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.7.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.0.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.1.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.2.0 [115/20] vi a 10.0.4 .6, Serial1/1
i L1 172.16.3.0 [115/20] vi a 10.0.4 .6, Serial1/1
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
i L1 10.0.2.0/24 [115/20] vi a 10.0.4 .1, Serial1/ 0
C 10.0.4.4/30 is directly connected, Serial1/ 1
C 10.0.4.0/30 is directly connected, Serial1/0
i L1 10.0.4.0/24 [115/20] vi a 10.0.4 .1, Serial1/0
i*L1 0.0.0.0/0 [115/10] vi a 10.0.4 .1, Serial1/0
-----------------------------------------------------------------------------------
R6
的:
Gateway of last resort is not set
140.140.0.0/16 is variably subnetted, 6 subnets, 2 masks
i L1 140.140.0.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i su 140.140.0.0/16 [115/20] via 0.0.0.0, Null0
i L1 140.140.1.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.2.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.3.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.4.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L2 172.16.0.0/16 [115/50] vi a 10.0.3 .1, Serial1/0
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L2 10.0.2.0/24 [115/20] vi a 10.0.3 .1, Serial1/ 0
C 10.0.3.0/30 is directly connected, Serial1/0
i L2 10.0.4.4/30 [115/40] vi a 10.0.3 .1, Serial1/0
i L2 10.0.0.0/24 [115/30] vi a 10.0.3 .1, Serial1/0
i L2 10.0.1.0/24 [115/20] vi a 10.0.3 .1, Serial1/ 0
C 10.0.3.4/30 is directly connected, FastEthernet0/0
i L2 10.0.4.0/30 [115/40] vi a 10.0.3 .1, Serial1/0
i L2 10.0.4.0/24 [115/30] vi a 10.0.3 .1, Serial1/0
i L2 130.130.0.0/16 [115/40] vi a 10.0.3 .1, Serial1/0
150.150.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 150.150.0.0/24 is directly connected, Loopback0
i su 150.150.0.0/16 [115/10] via 0.0.0.0, Null 0
C 150.150.1.0/24 is directly connected, Loopback 1
C 150.150.2.0/24 is directly connected, Loopback 2
C 150.150.3.0/24 is directly connected, Loopback 3
C 150.150.4.0/24 is directly connected, Loopback4
i L2 192.168.0.0/16 [115/20] vi a 10.0.3 .1, Serial1/0
i L1 140.140.0.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i su 140.140.0.0/16 [115/20] via 0.0.0.0, Null0
i L1 140.140.1.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.2.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.3.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L1 140.140.4.0/24 [115/20] vi a 10.0.3 .6, FastEthernet0/0
i L2 172.16.0.0/16 [115/50] vi a 10.0.3 .1, Serial1/0
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L2 10.0.2.0/24 [115/20] vi a 10.0.3 .1, Serial1/ 0
C 10.0.3.0/30 is directly connected, Serial1/0
i L2 10.0.4.4/30 [115/40] vi a 10.0.3 .1, Serial1/0
i L2 10.0.0.0/24 [115/30] vi a 10.0.3 .1, Serial1/0
i L2 10.0.1.0/24 [115/20] vi a 10.0.3 .1, Serial1/ 0
C 10.0.3.4/30 is directly connected, FastEthernet0/0
i L2 10.0.4.0/30 [115/40] vi a 10.0.3 .1, Serial1/0
i L2 10.0.4.0/24 [115/30] vi a 10.0.3 .1, Serial1/0
i L2 130.130.0.0/16 [115/40] vi a 10.0.3 .1, Serial1/0
150.150.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 150.150.0.0/24 is directly connected, Loopback0
i su 150.150.0.0/16 [115/10] via 0.0.0.0, Null 0
C 150.150.1.0/24 is directly connected, Loopback 1
C 150.150.2.0/24 is directly connected, Loopback 2
C 150.150.3.0/24 is directly connected, Loopback 3
C 150.150.4.0/24 is directly connected, Loopback4
i L2 192.168.0.0/16 [115/20] vi a 10.0.3 .1, Serial1/0
-----------------------------------------------------------------------------------
R7
的:
Gateway of last resort is 10.0.3 .5 to network 0.0.0.0
140.140.0.0/24 is subnetted, 5 subnets
C 140.140.0.0 is directly connected, Loopback 0
C 140.140.1.0 is directly connected, Loopback 1
C 140.140.2.0 is directly connected, Loopback 2
C 140.140.3.0 is directly connected, Loopback 3
C 140.140.4.0 is directly connected, Loopback4
10.0.0 .0/30 is subnetted, 2 subnets
i L1 10.0.3.0 [115/20] vi a 10.0.3 .5, FastEthernet0/ 0
C 10.0.3.4 is directly connected, FastEthernet0/0
150.150.0.0/24 is subnetted, 5 subnets
i L1 150.150.0.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.1.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.2.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.3.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.4.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] vi a 10.0.3 .5, FastEthernet0/0
C 140.140.0.0 is directly connected, Loopback 0
C 140.140.1.0 is directly connected, Loopback 1
C 140.140.2.0 is directly connected, Loopback 2
C 140.140.3.0 is directly connected, Loopback 3
C 140.140.4.0 is directly connected, Loopback4
10.0.0 .0/30 is subnetted, 2 subnets
i L1 10.0.3.0 [115/20] vi a 10.0.3 .5, FastEthernet0/ 0
C 10.0.3.4 is directly connected, FastEthernet0/0
150.150.0.0/24 is subnetted, 5 subnets
i L1 150.150.0.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.1.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.2.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.3.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i L1 150.150.4.0 [115/20] vi a 10.0.3 .5, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] vi a 10.0.3 .5, FastEthernet0/0
-----------------------------------------------------------------------------------
R8
的:
Gateway of last resort is not set
i L2 140.140.0.0/16 [115/50] vi a 10.0.0 .2, Serial1/0
i L2 172.16.0.0/16 [115/60] vi a 10.0.0 .2, Serial1/0
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L2 10.0.2.0/24 [115/30] vi a 10.0.0 .2, Serial1/0
i L2 10.0.3.0/30 [115/30] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.4/30 [115/50] vi a 10.0.0 .2, Serial1/ 0
C 10.0.0.0/24 is directly connected, Serial1/0
i L2 10.0.1.0/24 [115/20] vi a 10.0.0 .2, Serial1/0
i L2 10.0.3.4/30 [115/40] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.0/30 [115/50] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.0/24 [115/40] vi a 10.0.0 .2, Serial1/0
130.130.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 130.130.0.0/24 is directly connected, Loopback0
i su 130.130.0.0/16 [115/10] via 0.0.0.0, Null 0
C 130.130.1.0/24 is directly connected, Loopback 1
C 130.130.2.0/24 is directly connected, Loopback 2
C 130.130.3.0/24 is directly connected, Loopback3
i L2 150.150.0.0/16 [115/40] vi a 10.0.0 .2, Serial1/0
i L2 192.168.0.0/16 [115/10] vi a 10.0.0 .2, Serial1/0
i L2 172.16.0.0/16 [115/60] vi a 10.0.0 .2, Serial1/0
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
i L2 10.0.2.0/24 [115/30] vi a 10.0.0 .2, Serial1/0
i L2 10.0.3.0/30 [115/30] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.4/30 [115/50] vi a 10.0.0 .2, Serial1/ 0
C 10.0.0.0/24 is directly connected, Serial1/0
i L2 10.0.1.0/24 [115/20] vi a 10.0.0 .2, Serial1/0
i L2 10.0.3.4/30 [115/40] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.0/30 [115/50] vi a 10.0.0 .2, Serial1/0
i L2 10.0.4.0/24 [115/40] vi a 10.0.0 .2, Serial1/0
130.130.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 130.130.0.0/24 is directly connected, Loopback0
i su 130.130.0.0/16 [115/10] via 0.0.0.0, Null 0
C 130.130.1.0/24 is directly connected, Loopback 1
C 130.130.2.0/24 is directly connected, Loopback 2
C 130.130.3.0/24 is directly connected, Loopback3
i L2 150.150.0.0/16 [115/40] vi a 10.0.0 .2, Serial1/0
i L2 192.168.0.0/16 [115/10] vi a 10.0.0 .2, Serial1/0
-----------------------------------------------------------------------------------
R9
的:
Gateway of last resort is 10.0.4 .5 to network 0.0.0.0
172.16.0.0/24 is subnetted, 8 subnets
C 172.16.4.0 is directly connected, Loopback 4
C 172.16.5.0 is directly connected, Loopback 5
C 172.16.6.0 is directly connected, Loopback 6
C 172.16.7.0 is directly connected, Loopback 7
C 172.16.0.0 is directly connected, Loopback 0
C 172.16.1.0 is directly connected, Loopback 1
C 172.16.2.0 is directly connected, Loopback 2
C 172.16.3.0 is directly connected, Loopback3
10.0.0 .0/8 is variably subnetted, 4 subnets, 2 masks
i L1 10.0.2.0/24 [115/30] vi a 10.0.4 .5, Serial1/ 0
C 10.0.4.4/30 is directly connected, Serial1/0
i L1 10.0.4.0/30 [115/20] vi a 10.0.4 .5, Serial1/0
i L1 10.0.4.0/24 [115/30] vi a 10.0.4 .5, Serial1/0
i*L1 0.0.0.0/0 [115/20] vi a 10.0.4 .5, Serial1/0
C 172.16.4.0 is directly connected, Loopback 4
C 172.16.5.0 is directly connected, Loopback 5
C 172.16.6.0 is directly connected, Loopback 6
C 172.16.7.0 is directly connected, Loopback 7
C 172.16.0.0 is directly connected, Loopback 0
C 172.16.1.0 is directly connected, Loopback 1
C 172.16.2.0 is directly connected, Loopback 2
C 172.16.3.0 is directly connected, Loopback3
10.0.0 .0/8 is variably subnetted, 4 subnets, 2 masks
i L1 10.0.2.0/24 [115/30] vi a 10.0.4 .5, Serial1/ 0
C 10.0.4.4/30 is directly connected, Serial1/0
i L1 10.0.4.0/30 [115/20] vi a 10.0.4 .5, Serial1/0
i L1 10.0.4.0/24 [115/30] vi a 10.0.4 .5, Serial1/0
i*L1 0.0.0.0/0 [115/20] vi a 10.0.4 .5, Serial1/0
-----------------------------------------------------------------------------------