Lab - Configure RIPv2

Topology

 

Objective:

  • Configure RIPv2
  • Verify Connectivity

 

Background

Although RIP is rarely used in modern networks, it is useful as a foundation for understanding basic network routing. In this activity, you will configure a default route, RIP version 2, with appropriate network statements and passive interfaces, and verify full connectivity.

 

Step 1: Configure on R1.

a. Use the appropriate command to create a default route on R1 for all Internet traffic to exit the network through s1/1.
b. Enter RIP protocol configuration mode.
c. Use version 2 of the RIP protocol and disable the summarization of networks.
d. Configure RIP for the networks that connect to R1.
e. Configure the LAN port that contains no routers so that it does not send out any routing information.
f. Advertise the default route configured in step 1a with other RIP routers.
g. Save the configuration.

 

R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no autosummary

R1(config-router)#network 192.168.1.0

R1(config-router)#network 192.168.2.0

R1(config-router)#passive-interface f0/0

R1(config-router)#default-information originate

R1#write

 

Step 2: Configure RIPv2 on R2.
a. Enter RIP protocol configuration mode.
b. Use version 2 of the RIP protocol and disable the summarization of networks.
c. Configure RIP for the networks directly connected to R2.
d. Configure the interface that contains no routers so that it does not send out routing information.
e. Save the configuration.

 

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no autosummary

R2(config-router)#network 192.168.2.0

R2(config-router)#network 192.168.3.0

R1(config-router)#network 192.168.4.0

R1(config-router)#passive-interface f0/0

R1#write

 

Step 3: Configure RIPv2 on R3
Repeat Step 2 on R3.

 

 

R1#show ip route | begin Ga
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C    202.100.1.0/24 is directly connected, Serial1/1
R    192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:05, Serial1/0
R    192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:05, Serial1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:05, Serial1/0
S*   0.0.0.0/0 is directly connected, Serial1/1

 

R2#show ip route | begin Gateway
Gateway of last resort is 192.168.2.1 to network 0.0.0.0

C    192.168.4.0/24 is directly connected, Serial1/1
R    192.168.5.0/24 [120/1] via 192.168.4.2, 00:00:18, Serial1/1
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:17, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/0
C    192.168.3.0/24 is directly connected, FastEthernet0/0
R*   0.0.0.0/0 [120/1] via 192.168.2.1, 00:00:17, Serial1/0

 

 

R3#show ip route | b Ga  
Gateway of last resort is 192.168.4.1 to network 0.0.0.0

C    192.168.4.0/24 is directly connected, Serial1/1
C    192.168.5.0/24 is directly connected, FastEthernet0/0
R    192.168.1.0/24 [120/2] via 192.168.4.1, 00:00:04, Serial1/1
R    192.168.2.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial1/1
R    192.168.3.0/24 [120/1] via 192.168.4.1, 00:00:04, Serial1/1
R*   0.0.0.0/0 [120/2] via 192.168.4.1, 00:00:04, Serial1/1

 

R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 19 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Serial1/0             2     2                                    
    Serial1/1             2     2                                    
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.2.0
    192.168.3.0
    192.168.4.0
  Passive Interface(s):
    FastEthernet0/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.2.1          120      00:00:11
    192.168.4.2          120      00:00:11
  Distance: (default is 120)

 

 

 

你可能感兴趣的:(config)