PAT 1012 The Best Rank python解法

1012 The Best Rank (25分)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

解题思路

1.将数据存储为字典,key是学号,value是成绩。其中的平均分可以用总分代替,更节省时间。
2.按照不同科目分别对成绩进行排序。
3.找到最好的名次,输出排名和科目。
注:有一个测试点未通过,猜测为分数一样时名次也一样,后续再补。

n,m = map(int,input().split(' '))
dict1 = {}
for i in range(n):
    k,*v = map(int,input().split(' '))
    dict1[k] = v

for k1,v1 in dict1.items():
    dict1[k1].insert(0, sum(v1))
    
result = []
index = ['A','C','M','E']
for i in range(len(index)):
    list1 = [index[i]]+[_[0] for _ in sorted(dict1.items(),key=lambda x:x[1][i],reverse=True)]
    result.append(list1)

for j in range(m):
    key = int(input())
    if key in result[0]:
        rank_list = [rank.index(key) for rank in result]
        result_rank = [str(min(rank_list)),index[rank_list.index(min(rank_list))]]
        print(' '.join(result_rank))
    else:
        print('N/A')

PAT 1012 The Best Rank python解法_第1张图片

你可能感兴趣的:(用Python刷PAT,(Advanced,Level),Practice,python)