JAVA标识符

Java 标识符:用来表示类名,变量名,方法名,类型名,数组名,文件名的有效字符序列称为标识符。

规则:

1.只有字母(区分大小写),下划线,美元符号和数字组成,长度不受限制。

注:字母包括英文26个字母 ,汉字,日文,朝鲜文,俄文,希腊字母等。

2.第一个字母不能是数字。

3.不能是关键字

关键字(50):abstract    assert    boolean    break    byte    case    catch    char    class    const    continue    default

do    double    else    enum    extends    final    finally    float    for    goto    if    implements    import    instanceof    

int    interface    long    native    new    package    private    protected    public    return    short    static    strictfp

super    switch    synchronized    this    throw    throws    transient    try    void    volatile    while

4.不能是true false null(尽管三个都不是关键字)

判断Java标识符 : 

        Character.isJavaIdentifierStart(char ch)字符是否可以是Java标识符的第一个字符 ,真 true 假false

        Character.isJavaIdentifierPart(char ch)字符是否可以是除首字母以外的标识符 真true 假false

  

JAVA判断合法标识符

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Submit  Statistic

Problem Description

输入若干行字符串,判断每行字符串是否可以作为 JAVA语法的合法标识符。

Input

 输入有多行,每行一个字符串,字符串长度不超过 10个字符,以 EOF作为结束。

Output

 若该行字符串可以作为 JAVA标识符,则输出“ true;否则,输出“ false”。

Sample Input

abc
_test
$test
a 1
a+b+c
a’b
123
变量

Sample Output

true
true
true
false
false
false
false
true

import java.util.*;
public class Main
{    
    public static void main(String args[])
    { 
    	Scanner cin=new Scanner(System.in);  
    	String str;
    	boolean flag;
    	while(cin.hasNext())
    	{
    		str = cin.nextLine();
    		flag = valid(str);
    		if(flag==true) System.out.println("true");
    		else System.out.println("false");
    			
    	}
    	
        cin.close();
    }
    public static boolean valid(String str)  
    {  
        if(Character.isJavaIdentifierStart(str.charAt(0)))  
            // 如果第一个字符是Java合法的标识符,进入if语句  
        {  
            for(int i=1; i

你可能感兴趣的:(Java题目,Java知识)