[Review]Static PE-CE Routing

今天好多ISO的配置还是有些生疏 尤其是OSPF在ATM这些链路上的配置

OSPF over ATM 链路的情景

一定要考虑到 PVC 上配置broadcast

在接口下使能 ip ospf network broadcast

 

 

在此贴上配置:

#####R1##########

Router#show running-config
Building configuration...
Current configuration : 864 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!

interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 172.16.10.2 255.255.255.252
 duplex auto
 speed auto

!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.10.1
no ip http server
no ip http secure-server
!!
control-plane
!

!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

#######R2###########

Building configuration...

Current configuration : 1710 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip vrf 1
 rd 1:100
 route-target export 1:100
 route-target import 1:100
!

no ip ips deny-action ips-interface
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
interface Loopback0
 ip address 10.10.10.101 255.255.255.255

!

interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip vrf forwarding 1
 ip address 172.16.10.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM2/0
 ip address 10.10.10.1 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/200
  broadcast
  encapsulation aal5snap

 !
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.10.102 remote-as 1
 neighbor 10.10.10.102 update-source Loopback0
 no auto-summary
 !
 address-family v4
 neighbor 10.10.10.102 activate
 neighbor 10.10.10.102 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 1
 redistribute connected
 redistribute static
 no auto-summary
 no synchronization
 exit-address-family

!
ip classless
ip route vrf 1 1.1.1.1 255.255.255.255 172.16.10.2
no ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
 shutdown
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

 

#####R3###################

Router#show running-config
Building configuration...

Current configuration : 1131 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!

interface Loopback0
 ip address 10.10.10.200 255.255.255.255

!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface ATM1/0
 ip address 10.10.10.2 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/200
  broadcast
  encapsulation aal5snap

 !
!
interface ATM2/0
 ip address 10.10.10.5 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/300
  broadcast
  encapsulation aal5snap

 !
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

!
ip classless
no ip http server
no ip http secure-server!
!
control-plane!
!
gatekeeper
 shutdown!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4!
!
end

#####R4#####

Router#show running-config
Building configuration...

Current configuration : 1106 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
no ip dhcp use vrf connected
!
no ip ips deny-action ips-interface
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
interface Loopback0
 ip address 10.10.10.201 255.255.255.255

!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface ATM1/0
 ip address 10.10.10.6 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/300
  broadcast

 !
!
interface ATM2/0
 ip address 10.10.10.9 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/400
  broadcast
  encapsulation aal5snap

 !
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

!
ip classless
no ip http server
no ip http secure-server
!
control-plane
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

Router#

 

 

#####R5######

Router#show run
Building configuration...

Current configuration : 1711 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip vrf 1
 rd 1:100
 route-target export 1:100
 route-target import 1:100

!
no ip ips deny-action ips-interface
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
interface Loopback0
 ip address 10.10.10.102 255.255.255.255

!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip vrf forwarding 1
 ip address 172.16.20.1 255.255.255.252
 duplex auto
 speed auto

!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM2/0
 ip address 10.10.10.10 255.255.255.252
 ip ospf network broadcast
 no atm ilmi-keepalive
 mpls ip
 pvc 2/400
  broadcast
  encapsulation aal5snap

 !
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.10.101 remote-as 1
 neighbor 10.10.10.101 update-source Loopback0
 no auto-summary
 !
 address-family v4
 neighbor 10.10.10.101 activate
 neighbor 10.10.10.101 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 1
 redistribute connected
 redistribute static
 no auto-summary
 no synchronization
 exit-address-family
!

ip classless
ip route vrf 1 6.6.6.6 255.255.255.255 172.16.20.2
no ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

Router#

 

 

 

##########R6#########

Router#show run
Router#show running-config
Building configuration...

Current configuration : 864 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface

!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255

!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 ip address 172.16.20.2 255.255.255.252
 duplex auto
 speed auto

!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.20.1
no ip http server
no ip http secure-server
!
control-plane
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
line vty 0 4
!
!
end

 

 

你可能感兴趣的:(Networking)