PAT甲级 1069 The Black Hole of Numbers

PAT甲级 1069 The Black Hole of Numbers

题目链接
For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range ( 0 , 1 0 4 ) (0,10^4) (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

简单模拟,唯一的坑点就是要自动补零,python代码如下:

n=input().rjust(4,'0')
while 1:
    n=list(n)
    n=''.join(sorted(n))[::-1]
    print('{} - {} = {}'.format(n,n[::-1].rjust(4,'0'),str(int(n)-int(n[::-1])).rjust(4,'0')))
    n=str(int(n)-int(n[::-1])).rjust(4,'0')
    if int(n)==6174 or int(n)==0:
        break

你可能感兴趣的:(python,PAT甲级)