【Java】ZOJ刷题——1001 a+b problem

  • 任务与代码

【ZOJ1001】a+b problem

Calculate a + b
Input
The input will consist of a series of pairs of integers a and b,separated by a space, one pair of integers per line.
Output
For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.
Sample Input
1 5
Sample Output
6

AC代码如下:

/*
 *文件名称:Zoj1.java
 *作者:陈happy
 *完成日期:2019.10.25
 *
 *问题描述:将多个整数对中a、b相加
 *程序输出:a+b的结果(为输入的每一行输出)
 */
 
import java.util.Scanner;
public class Main{
	public static void main(String[] args) {		
		Scanner reader = new Scanner(System.in);
		int a,b;
		while(reader.hasNext()) {
		a=reader.nextInt();
        b=reader.nextInt();
        System.out.println(a+b);
		 }
	}
}
  • 运行结果
    【Java】ZOJ刷题——1001 a+b problem_第1张图片
  • 知识点总结:实现了对多组整数对的求和并输出。
  • 心得:
    1、英语是硬伤:刚开始草率读题,以为只是简单的a+b,Wrong Answer之后百思不得其解,后来用浏览器翻译了题目发现需要实现多对a、b的求和。
    2、这道题算是在ZOJ上的起步,希望自己可以坚持刷题,坚持发博客,好好理题目逻辑,好好练习java,加油!

你可能感兴趣的:(ZOJ刷题,Java)