动态NAT配置地址池和基于端口的NAT(PAT)配置

在这里 路由协议配置的是静态路由 rip 协议

router rip
 network 192.168.3.0
 network 200.1.1.0

配置如下图:
动态NAT配置地址池和基于端口的NAT(PAT)配置_第1张图片
在主机和服务器中设置完IP 子网掩码 网关之后,进行路由器的配置

动态路由NAT 地址池:
  • 路由B中
routerB:
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)# 
Router(config)#int f0/1       ----配置端口IP
Router(config-if)#ip addr 192.168.3.1 255.255.255.0
Router(config-if)#no sh

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#int f0/0     ----配置端口IP
Router(config-if)#ip addr 200.1.1.2 255.255.255.252
Router(config-if)#no sh

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#ex
Router(config)#


Router(config-if)#ex    
--配置rip路由协议,只有配置了路由协议才能ping通,有几个网络就要加几个网络号
Router(config)#router rip
Router(config-router)#netw
Router(config-router)#network 192.168.3.0
Router(config-router)#network 200.1.1.0
Router(config-router)#
  • 路由A中
routerA:
Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#int e0/1/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no sh

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1/0, changed state to up

Router(config-if)#int f0/1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no sh

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#ex
Router(config)#int f0/0
Router(config-if)#ip address 200.1.1.1 255.255.255.252
Router(config-if)#no sh


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config-if)#ex  
Router(config)#router rip
Router(config-router)#network
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.2.0
Router(config-router)#network 200.1.1.0
Router(config-router)#   ---以上 同路由B
Router(config)#ip route 0.0.0.0 0.0.0.0 200.1.1.2   ----设置默认路由
Router(config)#int f0/1  
Router(config-if)#ip nat inside    ---设置内网
Router(config-if)#ex
Router(config)#int e0/1/0
Router(config-if)#ip nat inside
Router(config-if)#int f0/0
Router(config-if)#ip nat outside    ---设置外网
Router(config-if)#ex
Router(config)#ip nat pool to_int 200.1.1.1 200.1.1.1 netmask 255.255.255.252   --设置地址池
Router(config)#

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255  --设置访问控制列表
Router(config)#access-list 1 permit 192.168.2.0 0.0.0.255
Router(config)#ip nat inside source list 1 pool to_int overload  --设置映射关系
Router(config)#

结果验证:查看

  • Router#show ip nat tran 查看是否使用了该端口号转换
  • Inside global:公网IP
  • Inside local:内网IP
  • Outside local:目的地址
  • 注意:目的地址没有转换

设置完之后验证:ping -t 192.168.3.33 
               然后在路由上Router#show ip nat tran
        
结果:
Pro  Inside global     Inside local       Outside local      Outside global
icmp 200.1.1.1:13      192.168.2.22:13    192.168.3.33:13    192.168.3.33:13
icmp 200.1.1.1:14      192.168.2.22:14    192.168.3.33:14    192.168.3.33:14
icmp 200.1.1.1:15      192.168.2.22:15    192.168.3.33:15    192.168.3.33:15
icmp 200.1.1.1:16      192.168.2.22:16    192.168.3.33:16    192.168.3.33:16
icmp 200.1.1.1:17      192.168.2.22:17    192.168.3.33:17    192.168.3.33:17
icmp 200.1.1.1:18      192.168.2.22:18    192.168.3.33:18    192.168.3.33:18

注:

Router(config)#ip nat pool to_int 200.1.1.1 200.1.1.1 netmask 255.255.255.252 
- ip nat pool 命令语句
- to_int      WORD  Pool name
- 200.1.1.1   Start IP address
- 200.1.1.1   End IP address
- netmask     掩码
- 255.255.255.252 掩码

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255 
- access-list 命令
- 1           list name
  <1-99>     IP standard access list  标准访问控制列表
  <100-199>  IP extended access list  扩展访问控制列表
- permit   
  deny    Specify packets to reject  禁止
  permit  Specify packets to forward  允许
  remark  Access list entry comment
- 0.0.0.255  子网掩码

Router(config)#ip nat inside source list 1 pool to_int overload 
- ip nat inside source 命令
- list
  list    Specify access list describing local addresses
  static  Specify static local->global mapping
- 1   访问列表名
  <1-199>  Access list number for local addresses
  WORD     Access list name for local addresses
- pool
  interface  Specify interface for global address  基于端口
  pool       Name pool of global addresses         基于地址池
- to_int     pool name
- overload   表示所有的主机都可以匹配该地址池中的地址
动态路由NAT 端口:
Router(config)#no ip nat inside source list 1  --把刚刚创建的访问控制列表删掉
Router(config)#access-list 2 permit 192.168.1.0 0.0.0.255  --创建访问控制列表
Router(config)#access-list 2 deny 192.168.2.0 0.0.0.255
Router(config)#ip nat inside source list 2  ?
  interface  Specify interface for global address
  pool       Name pool of global addresses
Router(config)#ip nat inside source list 2 interface f0/0 overload 
--在端口interface f0/0上应用该控制列表,地址池和端口也就是映射关系的不同
Router(config)#

设置完之后验证:

网络192.168.2.1中的主机
PC>ping -t 192.168.3.33

Pinging 192.168.3.33 with 32 bytes of data:

Reply from 192.168.3.33: bytes=32 time=70ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126


网络192.168.1.1中的主机
PC>ping -t 192.168.3.33

Pinging 192.168.3.33 with 32 bytes of data:

Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=50ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=51ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126
Reply from 192.168.3.33: bytes=32 time=51ms TTL=126
Reply from 192.168.3.33: bytes=32 time=60ms TTL=126

但是路由器中有信息,使用该端口
Router#show ip nat trans
Pro  Inside global     Inside local       Outside local      Outside global
icmp 200.1.1.1:110     192.168.1.11:110   192.168.3.33:110   192.168.3.33:110
icmp 200.1.1.1:111     192.168.1.11:111   192.168.3.33:111   192.168.3.33:111
icmp 200.1.1.1:112     192.168.1.11:112   192.168.3.33:112   192.168.3.33:112
icmp 200.1.1.1:113     192.168.1.11:113   192.168.3.33:113   192.168.3.33:113
icmp 200.1.1.1:114     192.168.1.11:114   192.168.3.33:114   192.168.3.33:114


结果分析:

然后在路由上Router#show ip nat tran,在路由器中 看不到网络192.168.2.1中的地址转换,表示没有使用该端口,但是还是可以ping通,因为在虚拟机中,
只要是配置了地址,和路由协议就会通过,但是在实际工作中,没有使用
公用IP的pool或者是端口转换,是不可以访问但外网的

你可能感兴趣的:(网络管理)