HDU - 5973 HDU - 5973 威佐夫博弈,高精度BigDecimal

#####Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
#####Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
#####Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
#####Sample Input
2 1
8 4
4 7
#####Sample Output
0
1
0

####分析:

典型的Wythoff,直接应用wythoff博弈的判定方法。但要注意的是,这里的精度需要达到10^100,用java的BigDecimal实现。学习了别人的代码。

####知识点:
1.类名要用Main;
2.BigDecimal的用法;
3.Scanner的用法;
4.二分求高精度根号5
####Code:

import java.math.BigDecimal;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        BigDecimal TWO = BigDecimal.valueOf(2);
        BigDecimal FIVE= BigDecimal.valueOf(5);
        BigDecimal EPS = new BigDecimal(
"-0.0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001");
        BigDecimal l = new BigDecimal("2.2360679774997");
        BigDecimal r = new BigDecimal("2.2360679774998");
        BigDecimal mid=null;

        //二分求sqrt(5)
        while (l.subtract(r).compareTo(EPS) < 0) {
            mid = l.add(r).divide(TWO);//mid = (l+r)>>1;
            if (mid.multiply(mid).subtract(FIVE).abs().compareTo(EPS.abs()) < 0) break;
            if (mid.multiply(mid).subtract(FIVE).compareTo(EPS) < 0) l = mid;
            else r = mid;
        }

        BigDecimal GOLD = mid.add(BigDecimal.ONE).divide(TWO);
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()) {
            BigDecimal a = sc.nextBigDecimal();
            BigDecimal b = sc.nextBigDecimal();
            if(a.compareTo(b)>0){
                BigDecimal t=a;a=b;b=t;
            }
            BigDecimal c=b.subtract(a).setScale(0,BigDecimal.ROUND_FLOOR).multiply(GOLD);
            c=c.setScale(0,BigDecimal.ROUND_FLOOR);
            if(a.equals(c)) System.out.println("0");
            else System.out.println("1");
        }
    }

}

你可能感兴趣的:(博弈和组合游戏,学习笔记)