如下是我已经规划好IP的物理拓扑图:
advise:在大家刚开始学习网络的时候建议大家把汇总路由各个地方的路由写在旁边,这样以便于自己二次学习;
实验要求:
1、ISP路由上只能配置IP地址,不得再进行其他任何操作
2、ISP的直连网段已经被规定,其余内网所有设备ip地址192.168.1.0/24划分
3、R1-R4每台设备存在两个环回
4、P0/P1自动获取IP地址
5、R1-R4均可ping通PC2;
6、PC2可以通过域名www.baidu.com访问HTTP服务器
7、PC2在TelnetR5的ip地址时,实际登录到R1上
8、VLAN2的所在网段只有PC0不能访问PC2
**下面我主要给大家简单讲讲合理的分配ip:**
首先两个环回我们要用一个子网,8个环回要用四个子网网段,所有的干路我们要用一个子网,所以我们要用5个子网,所以我们要借三位,即是/27 的掩码,其次拿一个子网给干路,又要借3位,就是/30的掩码,此时刚好可以给干路分配两个ip;其他四个ip子网各借一位即可;实际IP地址分配如上图;
我们一起来简单的分析一下实验要求:
1.ISP代表运营商的路由器,不能配置任何操作,可以分析此网络要定义内网网,做nat
2.主要是考察子网划分和合理的IP地址规划、精确汇总降低出现路由黑洞的概率
3.环回模拟用户
4.在R5上作DHCP池塘
5.作静态路由,R5上作nat,向外网作缺省
6.dns服务器的配置
7.作端口映射
8.用ACL访问控制列表对其进行限制
sever http的设置:
sever DNS的配置:
注意:pc2的DNS SEVER 的地址要写1.1.1.2!!!!
接下来让我们来show r吧!!
R1:
hostname xixi
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.65 255.255.255.240
!
interface Loopback1
ip address 192.168.1.81 255.255.255.240
!
interface FastEthernet0/0
ip address 192.168.1.17 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 1.1.1.0 255.255.255.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 192.168.1.18
ip route 0.0.0.0 0.0.0.0 192.168.1.6
ip route 192.168.1.128 255.255.255.224 192.168.1.18
ip route 192.168.1.32 255.255.255.224 192.168.1.6
ip route 192.168.1.8 255.255.255.252 192.168.1.18
ip route 192.168.1.0 255.255.255.252 192.168.1.6
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
R2:
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.129 255.255.255.240
!
interface Loopback1
ip address 192.168.1.145 255.255.255.240
!
interface FastEthernet0/0
ip address 192.168.1.18 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.9 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.10
ip route 192.168.1.64 255.255.255.224 192.168.1.17
ip route 192.168.1.32 255.255.255.224 192.168.1.17
ip route 192.168.1.32 255.255.255.224 192.168.1.10
ip route 192.168.1.4 255.255.255.252 192.168.1.17
ip route 192.168.1.0 255.255.255.252 192.168.1.10
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R3:
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.33 255.255.255.240
!
interface Loopback1
ip address 192.168.1.49 255.255.255.240
!
interface FastEthernet0/0
ip address 192.168.1.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.2
ip route 192.168.1.96 255.255.255.224 192.168.1.2
ip route 192.168.1.64 255.255.255.224 192.168.1.5
ip route 192.168.1.128 255.255.255.224 192.168.1.5
ip route 192.168.1.128 255.255.255.224 192.168.1.2
ip route 192.168.1.16 255.255.255.252 192.168.1.5
ip route 192.168.1.8 255.255.255.252 192.168.1.2
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R4:
hostname Router
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.97 255.255.255.240
!
interface Loopback11
ip address 192.168.1.113 255.255.255.240
!
interface FastEthernet0/0
ip address 192.168.1.10 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.1.13 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 192.168.1.21 255.255.255.252
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.14
ip route 192.168.1.128 255.255.255.224 192.168.1.9
ip route 192.168.1.32 255.255.255.224 192.168.1.1
ip route 192.168.1.64 255.255.255.224 192.168.1.9
ip route 192.168.1.64 255.255.255.224 192.168.1.1
ip route 192.168.1.16 255.255.255.252 192.168.1.9
ip route 192.168.1.4 255.255.255.252 192.168.1.1
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end
R5:
hostname wangcai
!
!
!
!
!
ip dhcp pool xixi
network 192.168.1.160 255.255.255.224
default-router 192.168.1.161
dns-server 8.8.8.8
!
no ip cef
no ipv6 cef
!
!
!
username xixi privilege 15 password 0 123
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.14 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.22 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 12.1.1.1 255.255.255.0
ip nat outside
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1.1
encapsulation dot1Q 2
ip address 192.168.1.161 255.255.255.224
ip access-group xixi in
ip nat inside
!
interface FastEthernet1/1.2
encapsulation dot1Q 3
ip address 3.3.3.4 255.0.0.0
ip nat inside
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 1 interface FastEthernet1/0 overload
ip nat inside source static tcp 192.168.1.17 23 12.1.1.1 23
ip nat inside source static tcp 3.3.3.3 80 12.1.1.1 80
ip classless
ip route 0.0.0.0 0.0.0.0 12.1.1.2
ip route 192.168.1.16 255.255.255.252 192.168.1.13
ip route 192.168.1.4 255.255.255.252 192.168.1.13
ip route 192.168.1.16 255.255.255.252 192.168.1.21 2
ip route 192.168.1.4 255.255.255.252 192.168.1.21 2
ip route 192.168.1.8 255.255.255.252 192.168.1.13
ip route 192.168.1.8 255.255.255.252 192.168.1.21 2
ip route 192.168.1.0 255.255.255.252 192.168.1.13
ip route 192.168.1.0 255.255.255.252 192.168.1.21 2
ip route 192.168.1.64 255.255.255.224 192.168.1.13
ip route 192.168.1.64 255.255.255.224 192.168.1.21 2
ip route 192.168.1.128 255.255.255.224 192.168.1.13
ip route 192.168.1.128 255.255.255.224 192.168.1.21 2
ip route 192.168.1.32 255.255.255.224 192.168.1.13
ip route 192.168.1.32 255.255.255.224 192.168.1.21 2
ip route 192.168.1.96 255.255.255.224 192.168.1.13
ip route 192.168.1.96 255.255.255.224 192.168.1.21 2
!
ip flow-export version 9
!
!
access-list 1 permit any
ip access-list extended xixi
deny icmp host 192.168.1.162 host 1.1.1.2 echo
permit ip any any
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login local
!
!
!
end
ISP:
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
ip address 12.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
!
line aux 0
!
line vty 0 4
login
!
!
!
end
上述就是我的全部配置了,希望能都帮到大家更好的学习网络!!!!