HDU-1069-java实现

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17820    Accepted Submission(s): 9527


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
 
   
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
 
   

Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342


动态规划,一个块有6种可能摆放的方式,按某种顺序给他排好(这里是长),然后用动态规划一个一个往后面dp吧,满足条件的话就给他堆上去。关键就是在于你得看出它这个块的摆放方式可以给他分开来,然后排序,不然的话你块跟块之间没什么关系的话你是没法给他dp的,因为dp是按照顺序下来的,你如果块与块之间都是散乱的顺序是不行的。

import java.util.Arrays; 
import java.util.Comparator;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		// TODO 自动生成的方法存根
     Scanner cin=new Scanner(System.in);
     Comparator cmp=new MyComparator();
     int Casenum=1;
     while(cin.hasNext())
     {   
    	 int N=cin.nextInt();
    	 if(N==0)break;
    	 block blocks[]=new block[6*N+1];
    	 int dp[]=new int[6*N+1];
    	 for(int i=1;i<=N;i++)
    	 {
    		int chang=cin.nextInt();
    		int kuan=cin.nextInt();
    		int gao=cin.nextInt();
    		blocks[i]=new block(chang,kuan,gao);
    		blocks[N+i]=new block(chang,gao,kuan);
    		blocks[2*N+i]=new block(gao,kuan,chang);
    		blocks[3*N+i]=new block(gao,chang,kuan);
    		blocks[4*N+i]=new block(kuan,chang,gao);
    		blocks[5*N+i]=new block(kuan,gao,chang);
    	 }
    	 Arrays.sort(blocks,1,6*N+1,cmp);
    	 for(int i=1;i<=6*N;i++)
    	 {
    		 dp[i]=blocks[i].height;
    	 }
    	 int max=0;
    	 for(int i=1;i<=6*N;i++)
    	 {
    		 for(int k=i-1;k>0;k--)
    		 {
    			 if(blocks[i].length

你可能感兴趣的:(HDU-动态规划,HDU-Java)