Seek the Name, Seek the Fame(哈希)

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:
Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).
Example: Father=‘ala’, Mother=‘la’, we have S = ‘ala’+‘la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
Input
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.
Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
Output
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
Sample Input
ababcababababcabab
aaaaa
Sample Output
2 4 9 18
1 2 3 4 5

解题思路

哈希还是比较强的,可以维护整个字符串的哈希数组,然后根据维护的哈希数组,求出开头的字符和末尾的字符比较是否相等。

#include<stdio.h>
#include<cstring>
using namespace std;
typedef unsigned long long ull;
const int maxn=1e6+10;
const ull base=223;
const ull mod=1e9+9;
ull hashes[maxn],p[maxn];
char s[maxn];
ull gethashes(int l,int r)
{
	return (hashes[r]%mod-(hashes[l-1]%mod*p[r-l+1]%mod)%mod+mod)%mod;//求出l到r的哈希值 
}
int main()
{
	while(~scanf("%s",s+1))
	{
		int len=strlen(s+1);
		p[0]=1;
		for(int i=1,j=len;i<=len;i++,j--)
		{
			hashes[i]=((hashes[i-1]%mod*base%mod)%mod+s[i]%mod)%mod;//维护这个数组 
			p[i]=(p[i-1]%mod*base%mod)%mod;//如果不理解的话,就把mod去掉,base看成10,用一串数字模拟一下 
		}
		bool flag=1;
		for(int i=1;i<=len;i++)
		{
			if(gethashes(0,i)==gethashes(len-i+1,len))
			if(flag) 
			{
				printf("%d",i);
				flag=0;
			}
			else printf(" %d",i);	
		}
		printf("\n");
	}
	return 0;
}

你可能感兴趣的:(哈希,KMP)