百炼OJ1005

描述 Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

百炼OJ1005_第1张图片

输入 The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given. 输出 For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.” 样例输入
2
1.0 1.0
25.0 0.0
样例输出
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.
这个题最大问题是鄙人英语太烂,看题目看了半天。这个题目大意是Fred在某点买了块土地,而河水从(0,0)开始以每年50平方英里的速度向外侵蚀,问哪年会侵蚀到Fred的地方。一个简单的中学数学问题。直接上代码:

import java.util.Scanner;

public class Main {
	public final static void main(String[] args){
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();
		double year=0;
		float x=0,y=0;
		for(int i=1;i<=n;i++){
			x=sc.nextFloat();
			y=sc.nextFloat();
			year=((x*x+y*y)*Math.PI/100);
			System.out.println("Property "+i+": This property will begin eroding in year "+((int)year+1)+".");
		}
		System.out.println("END OF OUTPUT.");
	}
}




你可能感兴趣的:(百炼OJ,算法,java)