静态路由实验:Dynagen-Dynamips + WinPcap + SecureCRT

静态路由实验

文章目录

  • 静态路由实验
    • 实验环境
    • 实验内容
      • 实验拓扑图
      • 实验内容
    • 实验步骤
        • 安装配置路由仿真环境
        • 完成 _.net_ 文件
        • 计算 **IOS** 的最佳 **idle-pc** 并储存
        • 仿真实验
          • 为每个接口配置**IP**地址
          • 为每台路由器配置静态路由
    • 总结分析
      • 遇到的问题及其分析解决
        • 计算 **IOS** 的最佳 **idle-pc**
        • Cisco 路由器命令含义
        • 路由器端口

实验环境

  • 主系统: macOS Catalina 10.15.4
  • 虚拟机系统:Windows 10 专业版 x64
  • 虚拟机软件:Parallels Desktop 15 for Mac Pro Edition, version 15.1.4 (47270)
  • 实验软件:Dynagen-Dynamips, WinPcap 4.1.3, SecureCRT 7.3

实验内容

实验拓扑图

实验内容

  1. 安装配置路由仿真环境:Dynagen-Dynamips + WinPcap + SecureCRT
  2. 写好表示能表示拓扑图设备、端口与直连关系的 .net 文件
  3. 计算 IOS 的最佳 idle-pc 并储存
  4. SecureCRT
    • 为每个接口配置IP地址
    • 为每台路由器配置静态路由并测试其连通性

实验步骤

安装配置路由仿真环境

按照说明书安装配置即可。

完成 .net 文件

按教程写好 .net 文件:

# test.net
#lab ipv4 static route
autostart = False

[localhost]
	port = 7200
	udp = 12000
	
	[[7200]]
		
		image = ..\..\images\c7200.bin
		
		ram = 160
		confreg = 0x2102
		
		slot0 = PA-C7200-IO-FE
		slot1 = PA-4T
		ghostios = True
		sparsemem = True
	
	[[ROUTER R1]]
		model = 7200
		console = 3001
		s1/0 = R2 s1/0
	
	[[router R2]]
		model = 7200
		console = 3002
		s1/1 = R4 s1/0
		f0/0 = R3 f0/0
	
	[[router R3]]
		model = 7200
		console = 3003
	
	[[router R4]]
		model = 7200
		console = 3004

	[[router PC1]]
		model = 7200
		console = 3005
		f0/0 = R1 f0/0

	[[router PC2]]
		model = 7200
		console = 3006
		f0/0 = R4 f0/0

	[[router PC3]]
		model = 7200
		console = 3007
		s1/0 = R3 s1/0

计算 IOS 的最佳 idle-pc 并储存

先启动 dynamips,再运行上面写好的 test.net。打开任务管理器,在 Dynagen 中启动路由器 R1

=> start R1

发现任务管理器中的 Dynamips (32 位) 占用 GPU 飙升到 50 % 50\% 50% 以上。打开 SecureCRTTelnetR1,任务管理器中该项占 GPU 继续升高:

Dynagen 中输入命令:

=> idlepc get R1

得到一系列 idle-pc 值。选择可能最佳的那个,发现任务管理器中的 Dynamips(32 位) 占用 GPU 迅速降低到个位数,于是将该 idle-pc 值存入数据库作为 IOSidle-pc 值:

仿真实验

Dynagen 中启动所有设备。打开 SecureCRTTelnet 到每个设备。

为每个接口配置IP地址

R1 为例。先进行 R1 的基本配置:

Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging synchronous
R1(config-line)#exit

再配置 R1 的每个端口:

R1(config)#interface f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.224
R1(config-if)#no shutdown 
R1(config-if)#exit
R1(config)#interface s1/0
R1(config-if)#ip address 192.168.1.65 255.255.255.224
R1(config-if)#no shutdown 
R1(config-if)#exit

其余路由器及主机均按同样方法配置。每配置完相连的端口后互相 ping 一下对方看是否正确设置并开启了端口。

为每台路由器配置静态路由

以下为所有路由器及主机的静态路由配置命令,注意主机也要配置静态路由:

# R1:
ip route 192.168.1.0 255.255.255.224 f0/0
ip route 192.168.1.192 255.255.255.224 192.168.1.66
ip route 10.1.0.0 255.255.0.0 192.168.1.66
ip route 10.4.6.0 255.255.255.0 192.168.1.66
ip route 10.4.7.0 255.255.255.0 192.168.1.66

# R2:
ip route 192.168.1.0 255.255.255.224 192.168.1.65
ip route 10.1.0.0 255.255.0.0 192.168.1.194
ip route 10.4.7.0 255.255.255.0 10.4.6.2

# R3:
ip route 10.1.0.0 255.255.0.0 s1/0
ip route 192.168.1.0 255.255.255.224 192.168.1.193
ip route 192.168.1.64 255.255.255.224 192.168.1.193
ip route 10.4.6.0 255.255.255.0 192.168.1.193
ip route 10.4.7.0 255.255.255.0 192.168.1.193

# R4:
ip route 10.4.7.0 255.255.255.0 f0/0
ip route 192.168.1.0 255.255.255.224 10.4.6.1
ip route 192.168.1.64 255.255.255.224 10.4.6.1
ip route 192.168.1.192 255.255.255.224 10.4.6.1
ip route 10.1.0.0 255.255.0.0 10.4.6.1

# pc1:
ip route 192.168.1.192 255.255.255.224 192.168.1.1
ip route 10.1.0.0 255.255.0.0 192.168.1.1
ip route 10.4.6.0 255.255.255.0 192.168.1.1
ip route 10.4.7.0 255.255.255.0 192.168.1.1
ip route 192.168.1.64 255.255.255.224 192.168.1.1

# pc2:
ip route 192.168.1.0 255.255.255.224 10.4.7.1
ip route 192.168.1.64 255.255.255.224 10.4.7.1
ip route 192.168.1.192 255.255.255.224 10.4.7.1
ip route 10.1.0.0 255.255.0.0 10.4.7.1
ip route 10.4.6.0 255.255.255.0 10.4.7.1

# pc3:
ip route 192.168.1.0 255.255.255.224 10.1.5.1
ip route 192.168.1.64 255.255.255.224 10.1.5.1
ip route 192.168.1.192 255.255.255.224 10.1.5.1
ip route 10.4.6.0 255.255.255.0 10.1.5.1
ip route 10.4.7.0 255.255.255.0 10.1.5.1

查看一下 R1 的路由表:

R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S       10.4.6.0/24 [1/0] via 192.168.1.66
S       10.4.7.0/24 [1/0] via 192.168.1.66
S       10.1.0.0/16 [1/0] via 192.168.1.66
     192.168.1.0/27 is subnetted, 3 subnets
C       192.168.1.64 is directly connected, Serial1/0
C       192.168.1.0 is directly connected, FastEthernet0/0
S       192.168.1.192 [1/0] via 192.168.1.66
R1#

当然,光看路由表是不能知道整个网络的静态路由设置是否正确的。所以在 PC1ping 一下自己,再 ping 一下其他两台主机:

pc1#ping 192.168.1.2 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
pc1#ping 10.1.5.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.5.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 140/192/288 ms
pc1#ping 10.4.7.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.4.7.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/232/320 ms
pc1#

均成功 ping 通!以同样方法测试其他两台主机也均成功,所以静态路由的配置是正确的,网络能够连通。

总结分析

遇到的问题及其分析解决

计算 IOS 的最佳 idle-pc

idle-pcCisco 路由器模拟平台 Dynamips 的一项功能,其作用在于降低模拟器对CPU的消耗。Dynamips 不知道什么时候虚拟路由器空闲,什么时候执行有用的工作。 “idlepc"命令对一个运行的映像进行分析确定在 IOS 中可能表现为一个 idle 循环的代码点. 一旦应用,当这个 idle 循环被执行 Dynamips “休眠” 虚拟路由器明显减少了主机的 CPU 消耗而不会降低虚拟路由器执行真实网络的能力。

Cisco 路由器命令含义

虽然有实验指导书,但对使用对命令没有多少介绍。为了能够正常使用命令,在网上查到了一个命令介绍进行学习。

路由器端口

在仿真时直接使用了 PPT 中的命令:

ip route 192.168.1.0 255.255.255.224 S0

提示命令不完整。使用:

ip route 10.1.0.0 255.255.0.0 E0

提示命令错误。

浏览了一下指导手册,发现里面的端口都是写成:

Serial1/0  Serial1/1  fastEthernet0/0  s1/0  s0/1  f0/0

诸如此类。于是去网上查了一下有关 Cisco 路由器端口表示的知识:

  • S口是serial接口的意思,也叫高速异步串口,主要是连接广域网的V.35线缆用的,说白了就是路由器和路由器连接时候用的,可以用命令设置带宽,一般也就在10M、8M左右。
  • F口是FastEthernet接口,叫快速以太网口,主要连接以太网(局域网)用的,说白了就是连接交换机或电脑用的,用普通的双绞线就可以连接,速率默认是100Mbps,可以用命令限速,但是不可能超过100Mbps。
  • E口是Ethernet接口,叫以太网接口,也是主要连接以太网(局域网)用的,也是用普通的双绞线就可以连接,速率默认是10Mbps,现在新型的设备上已经把这个接口淘汰了。
  • 另外,路由器上还有一个必不可少的接口是Console口,叫控制口,这个接口是用来调试路由器的。
  • 另外有的路由器还有AUX接口,也是控制接口;
  • G口,是千兆以太网接口,是连接以太网用的1

另外,有关其表示的知识:

  • S0口是集成式路由器上的同步串口,其命名方法是:类型+接口号
  • S1/0是模块化路由器上的同步接口,其命名方法是:类型+模块号/接口号

HAPPY!


  1. https://blog.csdn.net/immenselee/article/details/80401059 ↩︎

你可能感兴趣的:(cisco,internet,路由器,网络)