PAT甲级1003 Emergency 测试点2一直不通过的原因

1003 Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

使用Dijsktra算法的代码如下:

import java.awt.desktop.SystemSleepEvent;
import java.util.*;

public class Main {
     

    private static final int INF = Integer.MAX_VALUE;

    public static void main(String[] args) {
     
        Scanner scanner = new Scanner(System.in);
        int numberOfCity = scanner.nextInt();
        int numberOfRoad = scanner.nextInt();
        int start = scanner.nextInt();
        int end = scanner.nextInt();
        if (numberOfCity == 0) {
     
            System.out.print("0 0");
            return;
        }
        int[] rescues = new int[numberOfCity];
        int[][] matrix = new int[numberOfCity][numberOfCity];
        for (int i = 0; i < numberOfCity; i++)
            for (int j = 0; j < numberOfCity; j++)
                matrix[i][j] = INF;
        for (int i = 0; i < numberOfCity; i++)
            rescues[i] = scanner.nextInt();
        if (numberOfCity == 1) {
     
            System.out.print("1 " + rescues[0]);
            return;
        }
        for (int i = 0; i < numberOfRoad; i++) {
     
            int s = scanner.nextInt();
            int e = scanner.nextInt();
            int d = scanner.nextInt();
            matrix[s][e] = d;
            matrix[e][s] = d;
        }
        List<Vertex> vertexList = new ArrayList<>();
        int[] maxRescue = new int[numberOfCity];
        //初始化
        for (int i = 0; i < numberOfCity; i++) {
     
            maxRescue[i] = 0;
            if (i == start) {
     
                vertexList.add(new Vertex(start, 0, true));
            } else {
     
                vertexList.add(new Vertex(i, INF, false));
            }
        }
        for (Vertex v : vertexList) {
     
            if (!v.isVisit)
                if (matrix[start][v.vertex] != INF) {
     
                    v.number++;
                    v.distance = matrix[start][v.vertex];
                    maxRescue[v.vertex] = rescues[start] + rescues[v.vertex];
                }
        }
        //找最小路径
        for (int i = 0; i < numberOfCity - 1; i++) {
     
            int next = getMin(vertexList);
            vertexList.get(next).isVisit = true;
            for (int j = 0; j < numberOfCity; j++) {
     
                Vertex v = vertexList.get(j);
                if (!v.isVisit && matrix[next][j] != INF && v.distance > vertexList.get(next).distance + matrix[next][j]) {
     
                    v.distance = vertexList.get(next).distance + matrix[next][j];
                    maxRescue[v.vertex] = maxRescue[next] + rescues[v.vertex];
                    v.number = vertexList.get(next).number;
                } else if (!v.isVisit && v.distance == vertexList.get(next).distance + matrix[next][j]) {
     
                    maxRescue[v.vertex] = findMax(maxRescue[v.vertex], maxRescue[next] + rescues[v.vertex]);
                    v.number = v.number + vertexList.get(next).number;
                }
            }
        }
        System.out.print(vertexList.get(end).number + " " + maxRescue[end]);
    }

    private static int findMax(int a, int b) {
     
        return Math.max(a, b);
    }

    private static int getMin(List<Vertex> vertices) {
     
        int minD = INF;
        int index = -1;
        for (Vertex v : vertices) {
     
            if (v.isVisit) continue;
            if (v.distance < minD) {
     
                minD = v.distance;
                index = v.vertex;
            }
        }
        return index;
    }

    static class Vertex {
     
        int vertex;
        int number;
        int distance;
        boolean isVisit;

        public Vertex(int vertex, int distance, boolean isVisit) {
     
            this.vertex = vertex;
            this.distance = distance;
            this.isVisit = isVisit;
            number = 0;
        }
    }
}

关于测试点二一直不通过的原因:

考虑输入为一个城市的情况,如输入:

1 0 0 0
2

正确输出应为:

1 2

你可能感兴趣的:(PAT)