poj 3278 Catch That Cow

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 43187   Accepted: 13435

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

bfs+优先队列


#include"stdio.h"
#include"string.h"
#include"queue"
using namespace std;
#define N 100005
int mark[N],k,n;
struct node
{
	int x,step;
	friend bool operator<(node a,node b)
	{
		return a.step>b.step ;       //用时少的优先级高
	}
};
int judge(int x)
{
	if(x>=0&&(x<=n||xq;
	node cur,next;
	cur.x=x;
	cur.step=0;
	q.push(cur);
	mark[x]=1;
	while(!q.empty())
	{
		cur=q.top();
		if(cur.x==k)
			return cur.step;
		q.pop();
		next.step=cur.step+1;       

		next.x=cur.x+1;	//+1
		if(judge(next.x))
		{
			mark[next.x]=1;
			q.push(next);
		}

		next.x=cur.x-1;	 //-1
		if(judge(next.x))
		{
			mark[next.x]=1;
			q.push(next);
		}
		next.x=cur.x*2;	   //*2
		if(judge(next.x))
		{
			mark[next.x]=1;
			q.push(next);
		}
	}
	return 0;
}
int main()
{
	while(scanf("%d%d",&n,&k)!=-1)
	{
		memset(mark,0,sizeof(mark));
		printf("%d\n",bfs(n));
	}
	return 0;
}



你可能感兴趣的:(搜索)