[Python]PAT 甲级1001 A+B Format

[Python]PAT 甲级1001 A+B Format
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

a, b = map(int, input().split())
total = a + b
str_total = str(abs(total))
# print(str_total)
# 解决开头部分
pre = len(str_total)%3
if total < 0:
    print("-",end="")
i, j =0, 0
while i < pre:
    print(str_total[i],end="")
    i += 1
if i != 0 and total !=0 and len(str_total) > 3:
    print(",",end="")
str_total_left = str_total[pre: ]
while j < len(str_total_left):
    print(str_total_left[j],end="")
    if j % 3 == 2 and j != len(str_total_left)-1 :
        print(",",end="")
    j += 1

你可能感兴趣的:(PAT,Python,算法)