快速切题 sgu115. Calendar 模拟 难度:0

115. Calendar

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

 

First year of new millenium is gone away. In commemoration of it write a program that finds the name of the day of the week for any date in 2001.

 

Input

Input is a line with two positive integer numbers N and M, where N is a day number in month MN and M is not more than 100.

 

Output

Write current number of the day of the week for given date (Monday – number 1, … , Sunday – number 7) or phrase “Impossible” if such date does not exist.

 

Sample Input

21 10

Sample Output

7
#include <cstdio>

#include <cstring>

using namespace std;

const int date[12]={31,28, 31,30,31 ,30,31,31 ,30,31,30,31};

int main(){

    int day,month,orgdat=0;

    scanf("%d%d",&day,&month);month--;

    if((month<0||month>=12)||day<=0||day>date[month])puts("Impossible");

    else {for(int i=0;i<9;i++)orgdat+=date[i];

    orgdat+=21;

    orgdat=7-orgdat%7;

    for(int i=0;i<month;i++){

        orgdat+=date[i];

    }

    orgdat+=day;orgdat%=7;

    printf("%d\n",orgdat==0?7:orgdat);}

    return 0;

}

  

你可能感兴趣的:(calendar)