剑指offer面试题7——用两个栈实现队列

题目1512:用两个栈实现队列

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:3000

解决:1010

题目描述:

用两个栈来实现一个队列,完成队列的Push和Pop操作。
队列中的元素为int类型。

 

输入:

每个输入文件包含一个测试样例。
对于每个测试样例,第一行输入一个n(1<=n<=100000),代表队列操作的个数。
接下来的n行,每行输入一个队列操作:
1. PUSH X 向队列中push一个整数x(x>=0)
2. POP 从队列中pop一个数。

 

输出:

对应每个测试案例,打印所有pop操作中从队列pop中的数字。如果执行pop操作时,队列为空,则打印-1。

 

样例输入:
3

PUSH 10

POP

POP
样例输出:
10

-1
#include<iostream>

#include<stack>

#include<string>

#include<math.h>

using namespace std;

int str_int(string str)

{

	int len=str.size();

	int res=0;

	for(int i=0;i<len;i++)

	{

		res+=((str[i]-48)*pow(10.0,len-i-1));

	}

	return res;

}

int main()

{

	int n;

	cin>>n;



	fflush(stdin);

	stack<int> sta1;

	stack<int> sta2;

	while(n--)

	{

		string str;

		

		getline(cin,str);

		if(str[1]=='U')

		{

			string str1(str.begin()+5,str.end());

			//cout<<str1<<endl;

			int a=str_int(str1);

			//cout<<a<<endl;

			sta1.push(a);

		}

		else

		{

			if(sta1.empty())

				cout<<-1<<endl;

			else

			{

				while(!sta1.empty())

				{

					sta2.push(sta1.top());

					sta1.pop();

				}

				cout<<sta2.top()<<endl;

				sta2.pop();

				while(!sta2.empty())

				{

					sta1.push(sta2.top());

					sta2.pop();

				}

			}

		}

	}

}

  

你可能感兴趣的:(面试题)