(HDOJ 1019)Least Common Multiple

Least Common Multiple
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
3 5 7 15 
6 4 10296 936 1287 792 1
 

Sample Output
105 
10296
 

Source
 

Recommend
JGShining
 

 AC code:

#include  " stdio.h "
__int64 s[
1000 ];
__int64 hcf(__int64 a,__int64 b)
{
    __int64 r
= 0 ;

    
while (b != 0 )
    {
       r
= a % b;
       a
= b;
       b
= r;
    }
    
return (a);

__int64 lcd(__int64 u,__int64 v,__int64 h)
{
    
return (u * v / h);
}

int  main( int  argc,  char *  argv[])
{
 
int  n,m,i;
 
while (scanf( " %d " , & n) == 1 )
 {
  
while (n -- )
  {
   scanf(
" %d " , & m);
   
for (i = 0 ;i <= m - 1 ;i ++ )
    scanf(
" %I64d " , & s[i]);
   
for (i = 0 ;i <= m - 2 ;i ++ )
   { 
    s[i
+ 1 ] = lcd(s[i],s[i + 1 ],hcf(s[i],s[i + 1 ]));
   }
   printf(
" %I64d\n " ,s[m - 1 ]);

  }
 }
 
return   0 ;

} 

你可能感兴趣的:(com)