杭电acm1548 A string lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28432 Accepted Submission(s): 10231

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
5 1 5 3 3 1 2 5 0
 
Sample Output
3

Solution

这道题用广度优先搜索来解,但是应当注意程序中不要出现死循环,队列中不重复添加已有的楼层

Code

package acm1548;
 
/**
 * date:2017.12.08
 * author:孟小德
 * function:    杭电acm1548
 *      A strange lift
 */
 
import java.util.*;
 
class Node
{
    int floor,num,time;
    public Node(int floor,int num,int time)
    {
        this.floor = floor;
        this.num = num;
        this.time = time;
    }
    public Node()
    {}
}
 
public class Main
{
    public static int N,A,B;
    public static int[] lift;   //记录电梯每层信息
    public static int[] inflag;
 
    public static void BFS()
    {
        Node cur = new Node(A,lift[A],0);
        Queue nodeQ = new LinkedList();
        nodeQ.add(cur);
        inflag[A] = 0;
        while (!nodeQ.isEmpty())
        {
            Node nfloor = nodeQ.poll();
            if (nfloor.floor == B)
            {
                System.out.println(nfloor.time);
                return;
            }
            if (nfloor.time > N - 1)
            {
                System.out.println(-1);
            }
 
            int x = nfloor.floor + nfloor.num;
            if (x<=N && inflag[x] == 0)
            {
                inflag[x] = 1;
                nodeQ.add(new Node(x,lift[x],nfloor.time + 1));
            }
            x = nfloor.floor - nfloor.num;
            if (x>=1 && inflag[x] == 0)
            {
                inflag[x] = 1;
                nodeQ.add(new Node(x,lift[x],nfloor.time + 1));
            }
        }
        System.out.println(-1);
    }
 
    public static void main(String[] args)
    {
        Scanner input = new Scanner(System.in);
 
        while ((N = input.nextInt()) != 0)
        {
            A = input.nextInt();
            B = input.nextInt();
 
            lift = new int[N+1];
            inflag = new int[N+1];
            for (int i=1;i<=N;i++)
            {
                lift[i] = input.nextInt();
                inflag[i] = 0;
            }
 
            BFS();
 
        }
    }
}

你可能感兴趣的:(杭电acm1548 A string lift)