单词分析(第十一届蓝桥杯第二场省赛)

HashMap根据value值来排序

    • 【问题描述】
    • 【输入格式】
    • 【输出格式】
    • 【样例输入】
    • 【样例输出】
    • 【样例输入】
    • 【样例输出】

在使用HashMap或者其他容器时,我们经常碰到需要自定义排序,以这道省赛题为例,来看看怎么通过Collections来设置。

【问题描述】

小蓝正在学习一门神奇的语言,这门语言中的单词都是由小写英文字母组 成,有些单词很长,远远超过正常英文单词的长度。小蓝学了很长时间也记不 住一些单词,他准备不再完全记忆这些单词,而是根据单词中哪个字母出现得 最多来分辨单词。
现在,请你帮助小蓝,给了一个单词后,帮助他找到出现最多的字母和这 个字母出现的次数。

【输入格式】

输入一行包含一个单词,单词只由小写英文字母组成。

【输出格式】

输出两行,第一行包含一个英文字母,表示单词中出现得最多的字母是哪 个。如果有多个字母出现的次数相等,输出字典序最小的那个。
第二行包含一个整数,表示出现得最多的那个字母在单词中出现的次数。

【样例输入】

lanqiao

【样例输出】

a 2

【样例输入】

longlonglongistoolong

【样例输出】

o 6

思路还是挺简单的,就是将其放进HashMap中,通过比较value的值来排序,若是有相同的value的key,就先排字典序小的key,来看代码。

import java.util.*;

public class _12_G {
    public static void main(String[] args){
        String s =new Scanner(System.in).next();
        char[] nums= s.toCharArray();
        //System.out.println(Arrays.toString(nums));
        HashMap<Character,Integer> hashMap= new HashMap<>();
        for(char c:nums){
            hashMap.put(c,hashMap.getOrDefault(c,0)+1);//若是map中已经有该key了,就加1,没有的话,添加进去,并将value设为1
        }
        //借助list实现hashMap排序
        //注意ArrayList<>()括号里要传入map.entrySet()
        List<Map.Entry<Character,Integer>> list = new ArrayList<>(hashMap.entrySet());
        Collections.sort(list, new Comparator<Map.Entry<Character, Integer>>() {
            @Override
            public int compare(Map.Entry<Character, Integer> o1, Map.Entry<Character, Integer> o2) {
                //若是有相同的value
                if (o2.getValue()==o1.getValue()){
                    return o2.getKey()-o1.getKey();
                }
                //按照value值,从小到大排序
                return o2.getValue()-o1.getValue();
                //按照value值,从大到小排序
                //return o2.getValue()-o1.getValue();
                //按照value值,用compareTo()方法默认是从小到大
                //return o1.getValue().compareTo(o2.getValue());
            }
        });

        //注意这里遍历的是list,也就是我们将map.Entry放进里list,排序后的集合
//        for(HashMap.Entry a : list){
//            System.out.println(a.getKey());
//            System.out.println(a.getValue());
//        }
        System.out.println(list.get(0).getKey());
        System.out.println(list.get(0).getValue());
    }
}

排序的核心代码:

//借助list实现hashMap排序
        //注意ArrayList<>()括号里要传入map.entrySet()
        List<Map.Entry<Character,Integer>> list = new ArrayList<>(hashMap.entrySet());
        Collections.sort(list, new Comparator<Map.Entry<Character, Integer>>() {
            @Override
            public int compare(Map.Entry<Character, Integer> o1, Map.Entry<Character, Integer> o2) {
                //若是有相同的value
                if (o2.getValue()==o1.getValue()){
                    return o1.getKey()-o1.getKey();
                }
                //按照value值,从小到大排序
                return o2.getValue()-o1.getValue();
                //按照value值,从大到小排序
                //return o2.getValue()-o1.getValue();
                //按照value值,用compareTo()方法默认是从小到大
                //return o1.getValue().compareTo(o2.getValue());
            }
        });

若是其他容器也是这个思路,稍加修改后,便能使用

你可能感兴趣的:(蓝桥历年真题,hashmap)