As Easy As A+B
Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
Output
For each case, print the sorting result, and one line one case.
Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9
Sample Output
Author
lcy
AC code:
#include<stdio.h>
#define
N 1000
int
split(
int
a[],
int
low,
int
high)
{
int
part_element
=
a[low];
for
(;;){
while
(low
<
high
&&
part_element
<=
a[high])
high
--
;
if
(low
>=
high)
break
;
a[low
++
]
=
a[high];
while
(low
<
high
&&
a[low]
<=
part_element)
low
++
;
if
(low
>=
high)
break
;
a[high
--
]
=
a[low];
}
a[high]
=
part_element;
return
high;
}
void
quicksort(
int
a[],
int
low,
int
high)
{
int
middle;
if
(low
>=
high)
return
;
middle
=
split(a,low,high);
quicksort(a,low,middle
-
1
);
quicksort(a,middle
+
1
,high);
}
int
main()
{
int
m,n,i;
int
a[N];
scanf(
"
%d
"
,
&
n);
while
(n
--
)
{
scanf(
"
%d
"
,
&
m);
for
(i
=
0
; i
<
m; i
++
)
{
scanf(
"
%d
"
,
&
a[i]);
}
quicksort(a,
0
,m
-
1
);
for
(i
=
0
; i
<
m
-
1
; i
++
)
{
printf(
"
%d
"
,a[i]);
}
printf(
"
%d\n
"
,a[m
-
1
]);
//
注意:数组最后一个数后面没有空格,并且要注意换行!!!
}
return
0
;
}