HDU 1170 Balloon Comes!

Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. 
Is it very easy? 
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator. 
 
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 
Sample Input
4

+ 1 2

- 1 2

* 1 2

/ 1 2
 
Sample Output
3

-1

2

0.50
 

 

备注:题目要求当a能整除b时,输出整数。由于没看清楚题目,WR的我都纠结了。。

看题目要仔细呀

#include <stdio.h>

int main()

{

    int n,i,t,a,b;

    char k;

    float m;



    freopen("test.txt","r",stdin);



    scanf("%d",&n);

    for(i=0;i<n;i++)

    {

        scanf("%s",&k);

        scanf("%d %d",&a,&b);

        switch (k)

        {

            case '+':t=a+b;break;

            case '-':t=a-b;break;

            case '*':t=a*b;break;

            case '/':m=(float)a/b;break;

        }

        if(k=='/')

        {

            if(a%b==0)

                printf("%d\n",a/b);

            else

                printf("%.2f\n",m);

        }

        else

            printf("%d\n",t);

    }

    return 0;

}

 

你可能感兴趣的:(com)