31:Candies

总时间限制: 

1000ms

内存限制: 

65536kB

描述

There are N bags. Each bag has some candies. You can take some of the bags. the total number of candies in these bags should be a multiple of K because you want to divide the candies equally between K friends. How many candies can you take at most?

输入

First line: two positive integers N (N <= 100) and K (K <= 1000).
Second line: N positive integers (<= 1000).

输出

One integer.

样例输入

5 3
4 1 5 3 1

样例输出

12

#include//Writed by Wangzhimin Date: 2022.06.02 
using namespace std;
int num,k,a[205];
int main()
{
    scanf("%d%d",&num,&k);
    int tot=0; 
    for(int i=0;i     {
    scanf("%d",&a[i]);
    tot+=a[i];}//求出总数 
    sort(a,a+num);//排序 
    for(int i=0;i     {
        if(tot%k==0)//能分着吗 
        {
            cout<             break;
        }
        else
        tot-=a[i];//不能减去最小的 
    }
    return 0;
}

你可能感兴趣的:(c++)