九度OnlineJudge之1001:A+B for Matrices

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -6

0
样例输出:
1

5
#include <iostream>

#include<string.h>



using namespace std;



int main()

{

    int A[11][11];

    int B[11][11];

    int C[11][11];

    

    int M,N;

    int i,j;

    while(cin>>M>>N,M!=0)

    {

     int k =0;

    memset(A,0,sizeof(A));

    memset(B,0,sizeof(B));      

    memset(C,0,sizeof(C));    

      

      for(i=0;i<M;i++)

       for(j=0;j<N;j++)

          cin>>A[i][j];

          

     for(i=0;i<M;i++)

       for(j=0;j<N;j++)

          cin>>B[i][j]; 

          

     for(i=0;i<M;i++)

       for(j=0;j<N;j++)

         C[i][j]=A[i][j]+B[i][j]; 

         

     for(i=0;i<N;i++)

  {

     for(j=0;j<M;j++)

     { 

        if(C[j][i] != 0)

        break;               

     }

     if(j==M) k++;



  }      

    for(j=0;j<M;j++)

    {

       for(i=0;i<N;i++)

     { 

        if(C[j][i] != 0)

        break;               

     }

     if(i==N) k++;

  }             

    cout<<k<<endl;    

           

                     

    }

 

    

    

    

    

   // system("PAUSE");

    return 0;

}

你可能感兴趣的:(online)