字符串反转(指针实现)C++

【问题描述】

   从键盘输入一个长度不超过200的字符串,将该字符串反转后输出。

【输入形式】

  输入为一行一个字符串

【输出形式】

  输出反转后的字符串

【样例输入】

student
【样例输出】

tneduts

#include<iostream>
#include<cstring>
using namespace std;
void fun(char*s){
	char*p=s;
	char*q=s;
	char temp;
	while(*q)
	q++;
	q--;//找到最后一位
	while(p<q){
		temp=*p;
		*p=*q;
		*q=temp;
		*p++;
		*q--;
	}
}
int main(){
char str[201];
gets(str);
fun(str);
puts(str); 

return 0;
}

你可能感兴趣的:(笔记)