Radar Installation
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 56702 |
|
Accepted: 12792 |
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
思路就是,排序之后,按右端点放雷达就好
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=1010;
struct node{
double l,r;
}seg[N];
int cmp(node a,node b){
return a.l<b.l;
}
int main(){
//freopen("input.txt","r",stdin);
int n,d,cases=0;
while(~scanf("%d%d",&n,&d)){
if(n==0 && d==0)
break;
int x,y;
double tmp;
int flag=0;
for(int i=0;i<n;i++){
scanf("%d%d",&x,&y);
tmp=sqrt((double)(d*d)-y*y);
seg[i].l=x-tmp;
seg[i].r=x+tmp;
if(y>d)
flag=1;
}
sort(seg,seg+n,cmp);
printf("Case %d: ",++cases);
if(flag){
printf("-1\n");
continue;
}
int ans=1;
node line=seg[0];
for(int i=1;i<n;i++){
if(line.r<seg[i].l){
ans++;
line=seg[i];
}
else if(line.r>=seg[i].r)
line=seg[i];
}
printf("%d\n",ans);
}
return 0;
}