POJ 3041 Asteroids 最小点覆盖 == 二分图的最大匹配

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

#include <stdio.h>

#include <string.h>



int n, k, link[510];

bool map[510][510], vis[510];



bool dfs(int u)

{

    for(int v = 1; v <= n; v++)

    {

        if(map[u][v] && !vis[v])

        {

            vis[v] = 1;

            if(link[v] == -1 || dfs(link[v]))

            {

                link[v] = u;

                return 1;

            }

        }

    }

    return 0;

}



int main()

{

    int x, y;

    while(scanf("%d %d", &n, &k) != EOF)

    {

        memset(map, 0, sizeof(map));

        memset(link, -1, (n+1)*sizeof(int));

        while(k--)

        {

            scanf("%d %d", &x, &y);

            map[x][y] = 1;

        }

        int ans = 0;

        for(int i = 1; i <= n; i++)

        {

            memset(vis, 0, (n+1)*sizeof(bool));

            if(dfs(i))

                ans++;

        }

        printf("%d\n", ans);

    }

    return 0;

}
View Code

 

你可能感兴趣的:(poj)