实验一:Java程序的编辑、编译和运行(输入、输出)

Scanner类隶属于java.util包,以下列举一些Scanner类常用方法:

1.从键盘读入一行字符串,可以用如下代码:
Scanner in = new Scanner(System.in);
String name = in.nextLine()/next();
使用Scanner类,需要导入import java.util.Scanner;

2.从键盘读入一int/double/float数据(都当作整型数据处理),可以用如下代码:
Scanner in = new Scanner(System.in);
int/double/float n = in.nextInt()/nextDouble()/nextFloat();
使用Scanner类,需要导入import java.util.Scanner;

3.Scanner对象使用完毕后应当调用本方法将其关闭
in.close();

1.编写一个hello,world的Java程序。

【问题描述】编写一个Java程序,输入你的名字tom,在屏幕上输出“hello,tom!”。
【输入形式】名字字符串
【输出形式】hello,名字字符串!
【样例输入】tom
【样例输出】hello,tom!
【样例说明】
程序运行时,首先显示提示信息:What is your name?
然后,输入你的姓名,例如,tom。
最后,程序输出:hello,tom!

import java.util.Scanner;

public class Main
{
	public static void main(String[] args) 
	{
		System.out.println("What is your name?");
		Scanner in = new Scanner(System.in);
	    System.out.print("hello,"+in.nextLine()+"!");
	}
}

2.编写一个JAVA程序,在屏幕上输出

【问题描述】
编写一个JAVA程序,在屏幕上输出"This is my first (second, third, forth or fifth) JAVA code! "。
【输入形式】
首先显示提示信息:
This is your first, second, third, forth or fifth JAVA code?
然后,从键盘输入一个英文序号。
【输出形式】
输出This is my first (second, third, forth or fifth) JAVA code!
【样例输入①】
首先显示提示信息:
This is your first, second, third, forth or fifth JAVA code?
从键盘输入:
first
【样例输出①】
This is my first JAVA code!
【样例输入②】
首先显示提示信息:
This is your first, second, third, forth or fifth JAVA code?
从键盘输入:
second
【样例输出②】
This is my second JAVA code!

import java.util.Scanner;

public class Main
{
	public static void main(String[] args) 
	{
        System.out.println("This is your first, second, third, forth or fifth JAVA code?");
        Scanner in = new Scanner(System.in);
	    String n = in.nextLine();
        System.out.print("This is my "+n+ " JAVA code!");
	}
}

3.编写一个Java程序,用if-else语句判断某年份是否为闰年。

【问题描述】编写一个Java程序,用if-else语句判断某年份是否为闰年。
【输入形式】某年的年份
【输出形式】判断该年是否是闰年。
【样例输入】2008
【样例输出】2008 is leap year
【样例输入】2018
【样例输出】2018 is not leap year

import java.util.Scanner;

public class Main
{
	public static void main(String[] args) 
	{
		Scanner in = new Scanner(System.in);
		int year = in.nextInt();
		if(year%4==0) 
		{
			System.out.println(year+" is leap year");
		}
		else 
		{
			System.out.println(year+" is not leap year");
		}
	}
}

你可能感兴趣的:(Java编程题,java)