PAT 1004 Counting Leaves数叶子节点

1004 Counting Leaves (30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
dfs遍历树结构,得到每一层的叶子节点的数目
def dfs(node,depth):
    visited[node]=True
    global max_depth
    max_depth=max(depth,max_depth)
    if node not in tree:
        number_of_leaf[depth]+=1
        return
    for child in tree[node]:
        if child not in visited:
            dfs(child,depth+1)

n,m=list(map(int,input().split()))
tree={}
max_depth=0
number_of_leaf=[0]*(n+1)
visited={}
for i in range(m):
    nodeId,nodeNumber,*childId=input().split()
    tree[nodeId]=childId
dfs('01',0)

你可能感兴趣的:(PAT 1004 Counting Leaves数叶子节点)