POJ 2386(DFS)

深度优先搜索属于图算法的一种,英文缩写为DFS即Depth First Search.其过程简要来说是对每一个可能的分支路径深入到不能再深入为止,而且每个节点只能访问一次.

举例说明之:下图是一个无向图,如果我们从A点发起深度优先搜索(以下的访问次序并不是唯一的,第二个点既可以是B也可以是C,D),则我们可能得到如下的一个访问过程:A->B->E(没有路了!回溯到A)->C->F->H->G->D(没有路,最终回溯到A,A也没有未访问的相邻节点,本次搜索结束).简要说明深度优先搜索的特点:每次深度优先搜索的结果必然是图的一个连通分量.深度优先搜索可以从多点发起.如果将每个节点在深度优先搜索过程中的"结束时间"排序(具体做法是创建一个list,然后在每个节点的相邻节点都已被访问的情况下,将该节点加入list结尾,然后逆转整个链表),则我们可以得到所谓的"拓扑排序",即topological sort.

图
深度优先遍历图的方法是,从图中某顶点v出发:
(1)访问顶点v;
(2)依次从v的未被访问的邻接点出发,对图进行 深度优先遍历;直至图中和v有路径相通的顶点都被访问;
(3)若此时图中尚有顶点未被访问,则从一个未被访问的顶点出发,重新进行 深度优先遍历,直到图中所有顶点均被访问过为止。 当然,当人们刚刚掌握深度优先搜索的时候常常用它来走迷宫.事实上我们还有别的方法,那就是 广度优先搜索(BFS).

 

http://poj.org/problem?id=2386

 

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19801   Accepted: 9955

 

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12

W........WW.

.WWW.....WWW

....WW...WW.

.........WW.

.........W..

..W......W..

.W.W.....WW.

W.W.W.....W.

.W.W......W.

..W.......W.

Sample Output

3
#include<stdio.h>

#include<math.h>

#include<algorithm>

using namespace std;

int m,n;

char field[105][105];  //全局变量好

void dfs(int x,int y);

int main()

{

	while(~scanf("%d%d",&m,&n))

	{



		int i, j, t = 0;

		for(i=0;i<m;i++)

		{

			getchar(); //记得加上

			for(j=0;j<n;j++)

			{

				scanf("%c",&field[i][j]);

			}

		}

		for(i=0;i<m;i++)

		{

			for(j=0;j<n;j++)

			{

				if(field[i][j] == 'W')

				{

					dfs(i,j);

					t++;

				}

			}

		}

		printf("%d\n",t);

	}

}



void dfs(int x,int y)

{

	int i, j;

	field[x][y] = '.'; //标记走过

	for(i = -1; i < 2; i++)

	{

		for(j = -1; j < 2; j++)

		{		//遍历这个店相邻的8个点

			int nx = x + i, ny = y + j;

			if(nx >=0 && nx < m && ny >= 0 && ny < n && field[nx][ny] == 'W'){

				dfs(nx,ny);

			}

		}

	}

	return;

}



你可能感兴趣的:(poj)