hdoj 1879 继续畅通工程

继续畅通工程

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 10967    Accepted Submission(s): 4791

Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
 

 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

 

Sample Input
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

 

Sample Output
3 1 0
 
 
Prim算法水过
//9435177    2013-10-28 15:14:23    Accepted    1879    843MS    332K    1461 B    C++    空信高手

#include <iostream>



using namespace std;

#define typec int

#define V 101

const typec inf=0x3f3f3f3f;

int vis[V];

int cost[V][V];

typec lowc[V];

/*==================================================*\

 | Prim求MST

 | INIT: cost[][]耗费矩阵(inf为无穷大);

 | CALL: prim(cost, n); 返回-1代表原图不连通;

\*==================================================*/

typec prim(int n)

{

    int i,j,p;

    typec minc,res=0;

    memset(vis,0,sizeof(vis));

    vis[0]=1;

    for(i=1; i<n; i++) lowc[i]=cost[0][i];

    for(i=1; i<n; i++)

    {

        minc=inf;

        p=-1;

        for(j=0; j<n; j++)

        {

            if(0==vis[j]&&minc>lowc[j])

            {

                minc=lowc[j];

                p=j;

            }

        }

        if(inf==minc) return -1;

        res+=minc;

        vis[p]=1;

        for(j=0; j<n; j++)

            if(0==vis[j]&&lowc[j]>cost[p][j])lowc[j]=cost[p][j];

    }

    return res;

}

void Init()

{

    int i,j;

    for(i=0; i<V; i++)

        for(j=0; j<V; j++)

            cost[i][j]=10000000;

}



int main()

{

   // freopen("input.txt","r",stdin);

    int i,a,b,dis,flag,n;

    while(cin>>n&&n!=0)

    {

        Init();

        for(i=0;i<n*(n-1)/2;i++)

        {

            cin>>a>>b>>dis>>flag;

            if(flag==1) cost[a-1][b-1]=cost[b-1][a-1]=0;

            else cost[a-1][b-1]=cost[b-1][a-1]=dis;

        }

        cout<<prim(n)<<endl;

    }

    return 0;

}

 

 
 
 

你可能感兴趣的:(OJ)