PAT 甲级 刷题日记|A 1122 Hamiltonian Cycle (25 分)

单词积累

vertex 顶点

Hamilton cycle problem 哈密顿问题

题目

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
结尾无空行

Sample Output:

YES
NO
NO
NO
YES
NO

思路

简单的环路问题,涉及到基本的知识点,图的存储。

代码

# include 
using namespace std;

const int maxn = 200;
int graph[maxn][maxn];

int main() {
    int N, M;
    cin>>N>>M;
    int te1, te2;
    for (int i = 0; i < M; i++) {
        cin>>te1>>te2;
        graph[te1][te2] = graph[te2][te1] = 1;
    }
    int cnt;
    cin>>cnt;
    while (cnt--) {
        vector que;
        set s;
        int len;
        cin>>len;
        int num;
        int flag1 = 1;
        int flag2 = 1;
        
        for (int i = 0; i < len; i++) {
            cin>>num;
            que.push_back(num);
            s.insert(num);
        }
        if (s.size() != N || len - 1 != N || que[0] != que[len - 1]) {
            flag1 = 0;
        }
        for (int i = 0; i < len - 1; i++) {
            if (graph[que[i]][que[i+1]] == 0) flag2 = 0;
        }
        printf("%s",flag1 && flag2 ? "YES\n" : "NO\n");
    }
    return 0;
}

你可能感兴趣的:(PAT 甲级 刷题日记|A 1122 Hamiltonian Cycle (25 分))