Guess

Problem A: Guess

Time Limit: 1 Sec  Memory Limit: 32 MB

Description


In the television program "Shopping Street" of CCTV-2, two people, A and B are guessing the price of a given item. You are asked to decide whose price is closer to the real price.

 

Input

 

There are multiple test cases. The first line of input is an integer T (T <= 20) indicating the number of test cases.

Each case contains three integers in one line: P, PA, PB (0 <= PA, PB, P <= 100, | PA – P | != | PB – P |), indicating the real price, the price A guesses and the price B guesses.

 

Output

 

For each case, output "A" or "B" according to whose price is closer to the real price.

 

Sample Input

4

10 8 7

20 20 19

100 9 50

50 39 60

Sample Output

A

A

B

B

HINT

简单题 直接上代码:

#include<stdio.h>

#include<string.h>

 

int main()

{

    int t,a,b,c;

    scanf("%d",&t);

    while(t--)

    {

        scanf("%d%d%d",&a,&b,&c);

        b = (b-a)>0?(b-a):(a-b);

        c = (c-a)>0?(c-a):(a-c);

        if(b>c) printf("B\n");

        else printf("A\n");

    }

    return 0;

}

 

 

/**************************************************************

    Problem: 1

    User: Hui

    Language: C

    Result: 正确

    Time:0 ms

    Memory:964 kb

****************************************************************/

 

 

你可能感兴趣的:(UE)