10025 - The ? 1 ? 2 ? ... ? n = k problem

/*

 

 The ? 1 ? 2 ? ... ? n = k problem 

The problem

Given the following formula, one can set operators '+' or '-' instead of each '?', in order to obtain a given k
? 1 ? 2 ? ... ? n = k

For example: to obtain k = 12 , the expression to be used will be:
- 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12
with n = 7

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains integer k (0<=|k|<=1000000000).

Each test case will be separated by a single line.

The Output

For each test case, your program should print the minimal possible n (1<=n) to obtain k with the above formula.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2



12



-3646397

Sample Output

7



2701

注意:用1到n中的某几个数可表示任意的整数s(n+1=<s<=n*(n+1)/2)

*/

#include<stdio.h>
#include<math.h>
int main()
{
 int k,n,i,j,s;
 scanf("%d",&n);
    for(j=0;j<n;j++)
 {
  if(j)
   printf("\n");
  scanf("%d",&k);
  if(k==0)
  {
   printf("3\n");
   continue;
  }
  k=abs(k);
  i=(int)sqrt(2*k);
  s=i*(i+1)/2;
  while(s<k)
  {
   i++;
   s+=i;
  }
  while((s-k)%2)
  {
   i++;
   s+=i;
  }
  printf("%d\n",i);
 }
 return 0;
}

你可能感兴趣的:(em)