[POJ 1442] Black Box

Black Box
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 7770   Accepted: 3178

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions: 

ADD (x): put element x into Black Box; 
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending. 

Let us examine a possible sequence of 11 transactions: 

Example 1 

N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type. 


Let us describe the sequence of transactions by two integer arrays: 


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2). 

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6). 

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence. 


Input

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.

Output

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.

Sample Input

7 4

3 1 -4 2 8 -1000 2

1 2 6 6

Sample Output

3

3

1

2
 
#include <iostream>

#include <stdio.h>

#include <time.h>

using namespace std;

#define N 30100

#define INF 0x7fffffff



int val[N];

struct Treap

{

    int ch[N][2],fix[N],size[N];

    int top,root;

    

    inline void PushUp(int rt)

    {

        size[rt]=size[ch[rt][0]]+size[ch[rt][1]]+1;

    }

    void Newnode(int &rt,int v)

    {

        rt=++top;

        val[rt]=v;

        size[rt]=1;

        fix[rt]=rand();

        ch[rt][0]=ch[rt][1]=0;

    }

    void Init()

    {

        top=root=0;

        ch[0][0]=ch[0][1]=0;

        size[0]=val[0]=0;

        memset(size,0,sizeof(size));

    }

    void Rotate(int &x,int kind)

    {

        int y=ch[x][kind^1];

        ch[x][kind^1]=ch[y][kind];

        ch[y][kind]=x;

        PushUp(x);

        PushUp(y);

        x=y;

    }

    void Insert(int &rt,int v)

    {

        if(!rt)

            Newnode(rt,v);

        else

        {

            int kind=(v>=val[rt]);

            size[rt]++;

            Insert(ch[rt][kind],v);

            if(fix[ch[rt][kind]]<fix[rt])

                Rotate(rt,kind^1);

        }

    }

    int Find(int rt,int k)

    {

        int cnt=size[ch[rt][0]];

        if(k==cnt+1) return val[rt];

        else if(k<=cnt) return Find(ch[rt][0],k);

        else return Find(ch[rt][1],k-cnt-1);

    }

}t;

int main()

{

    int n,i,m;

    srand((int)time(0));

    while(scanf("%d%d",&n,&m)!=EOF)

    {

        t.Init();

        for(i=1;i<=n;i++)

        {

            scanf("%d",&val[i]);

        }

        int last=1,x;

        for(i=1;i<=m;i++)

        {

            scanf("%d",&x);

            while(last<=x)

            {

                t.Insert(t.root,val[last]);

                last++;

            }

            printf("%d\n",t.Find(t.root,i));

        }

    }

    return 0;

}

 

你可能感兴趣的:(poj)