HDU 2032 杨辉三角 分类: ACM 2015-07-11 18:28 6人阅读 评论(0) 收藏

杨辉三角

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43688    Accepted Submission(s): 18368


Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
 

Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
 

Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
 

Sample Input
  
    
2 3
 

Sample Output
  
    
1 1 1 1 1 1 1 2 1
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2036  1096  2049  1108  2072

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 33
int n;

int main()
{
	while(~scanf("%d",&n))
	{
		int a[N][N];
		a[1][1]=1;
		a[2][1]=a[2][2]=1;
		for(int i=3;i<=n;i++)
		{
			for(int j=1;j<=i;j++)
			{
				if(j==1){a[i][j]=1;continue;}
				if(j==i){a[i][j]=1;continue;}
				a[i][j]=a[i-1][j-1]+a[i-1][j];
			}
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<i;j++)
				cout<<a[i][j]<<' ';
			cout<<a[i][i]<<endl;
		}
		cout<<endl;

	}
    return 0;
}



//freopen("1.txt", "r", stdin);
    //freopen("2.txt", "w", stdout);
//**************************************



 

版权声明:本文为博主原创文章,未经博主允许不得转载。

你可能感兴趣的:(ACM)