HDU 2044 一只小蜜蜂 分类: ACM 2015-07-10 22:51 10人阅读 评论(0) 收藏

今天要去找她 所以不能写了

/******************************************/

一只小蜜蜂...

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47355    Accepted Submission(s): 17271


Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。

 

Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
 

Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
 

Sample Input
  
    
2 1 2 3 6
 

Sample Output
  
    
1 3
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2045  2050  2049  1297  1290

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 55
int n;

int main()
{
	__int64 f[N];
	f[1]=1;f[2]=2;
	for(int i=3;i<=52;i++)
		f[i]=f[i-1]+f[i-2];
	int t;cin>>t;
	while(t--)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		int c=a-b;
		if(c<0)c=-c;
		cout<<f[c]<<endl;
	}
    return 0;
}



//freopen("1.txt", "r", stdin);
    //freopen("2.txt", "w", stdout);
//**************************************



 

版权声明:本文为博主原创文章,未经博主允许不得转载。

你可能感兴趣的:(ACM)