hdu 3309 Roll The Cube ( bfs )

Roll The Cube

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 345    Accepted Submission(s): 127

 

Problem Description
This is a simple game.The goal of the game is to roll two balls to two holes each.
'B' -- ball
'H' -- hole
'.' -- land
'*' -- wall
Remember when a ball rolls into a hole, they(the ball and the hole) disappeared, that is , 'H' + 'B' = '.'.
Now you are controlling two balls at the same time.Up, down , left , right --- once one of these keys is pressed, balls exist roll to that direction, for example , you pressed up , two balls both roll up.
A ball will stay where it is if its next point is a wall, and balls can't be overlap.
Your code should give the minimun times you press the keys to achieve the goal.
 

 

Input
First there's an integer T(T<=100) indicating the case number.
Then T blocks , each block has two integers n , m (n , m <= 22) indicating size of the map.
Then n lines each with m characters.
There'll always be two balls(B) and two holes(H) in a map.
The boundary of the map is always walls(*).
 

 

Output
The minimum times you press to achieve the goal.
Tell me "Sorry , sir , my poor program fails to get an answer." if you can never achieve the goal.
 

 

Sample Input
4 6 3 *** *B* *B* *H* *H* *** 4 4 **** *BB* *HH* **** 4 4 **** *BH* *HB* **** 5 6 ****** *.BB** *.H*H* *..*.* ******
 

 

Sample Output
3 1 2 Sorry , sir , my poor program fails to get an answer.
 

 

Author
MadFroG
 

 

Source


思路:
bfs,用两个球的位置来判重,其他的直接模拟就ok了。最好将球和洞分开看,还有就是注意一下两个球不能在同一个位置。

代码:
#include <iostream>

#include <cstdio>

#include <cstring>

#include <queue>

#define maxn 25

#define INF 0x3f3f3f3f

using namespace std;



int n,m,ans;

int sx[2],sy[2];

int dx[]= {-1,1,0,0};

int dy[]= {0,0,-1,1};

bool vis[maxn][maxn][maxn][maxn];

char mp[maxn][maxn];

char s[maxn];

struct Node

{

    int x[2],y[2],step;

    int b[2],h[2];   // 球 洞  球是否进洞和洞是否被求填满分开看

} cur,now;

queue<Node>q;



bool bfs()

{

    int i,j,t,flag;

    memset(vis,0,sizeof(vis));

    while(!q.empty()) q.pop();

    cur.x[0]=sx[0],cur.y[0]=sy[0];

    cur.x[1]=sx[1],cur.y[1]=sy[1];

    cur.h[0]=cur.h[1]=0;

    cur.b[0]=cur.b[1]=0;

    cur.step=0;

    vis[sx[0]][s[0]][sx[1]][sy[1]]=1;

    q.push(cur);

    while(!q.empty())

    {

        now=q.front();

        q.pop();

        for(i=0; i<4; i++)

        {

            cur=now;

            for(j=0; j<2; j++)

            {

                if(cur.b[j]) continue ;

                cur.x[j]+=dx[i];

                cur.y[j]+=dy[i];

                if(mp[cur.x[j]][cur.y[j]]=='*')

                {

                    cur.x[j]-=dx[i];

                    cur.y[j]-=dy[i];

                }

            }

            if(vis[cur.x[0]][cur.y[0]][cur.x[1]][cur.y[1]]||cur.x[0]==cur.x[1]&&cur.y[0]==cur.y[1]&&cur.b[0]+cur.b[1]==0) continue ;

            cur.step++;

            vis[cur.x[0]][cur.y[0]][cur.x[1]][cur.y[1]]=1;

            flag=1;

            for(j=0; j<2; j++)

            {

                t=mp[cur.x[j]][cur.y[j]];

                if(t<2&&!cur.h[t]) cur.b[j]=1,cur.h[t]=1;

                if(!cur.b[j]) flag=0;

            }

            if(flag)

            {

                ans=cur.step;

                return true ;

            }

            q.push(cur);

        }

    }

    return false ;

}

int main()

{

    int i,j,t,cnt1,cnt2;

    scanf("%d",&t);

    while(t--)

    {

        scanf("%d%d",&n,&m);

        cnt1=cnt2=0;

        for(i=1; i<=n; i++)

        {

            scanf("%s",s);

            for(j=1; j<=m; j++)

            {

                mp[i][j]=s[j-1];

                if(mp[i][j]=='H') mp[i][j]=cnt1++;

                else if(mp[i][j]=='B') sx[cnt2]=i,sy[cnt2]=j,cnt2++;

            }

        }

        if(bfs()) printf("%d\n",ans);

        else printf("Sorry , sir , my poor program fails to get an answer.\n");

    }

    return 0;

}



 

 

你可能感兴趣的:(cube)