poj 1287 networking

/*
大概题意:
给一些点,某些点之间有一些路(存在两点之间有多条路),告诉你路径的起点终点和长度,问将所有点连通(可直接也可间接),路径总长至少多长.
*/

/*
Networking
Time Limit: 1000MS		Memory Limit: 10000K
Total Submissions: 5510		Accepted: 2970
Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 
Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0
Sample Output

0
17
16
26
Source

Southeastern Europe 2002
*/


#include <cstdio>
#include <cstdlib>
#include <queue>
#include <algorithm>
using namespace std;

//路径类
class rot
{
public:
	int sr;
	int de;
	int len;
	rot(int s, int d, int l):sr(s), de(d), len(l){};
};

//重载小于号 便于priority_queue按照路径长度排序
bool operator<(rot a, rot b)
{
	return a.len > b.len;
}

//节点类 用于并查集查是否连通
class node
{
public:
	node* father;
	node():father(NULL){};
};

//并查集获取祖先
node* getori(node* a)
{
	if (a -> father == NULL) return a;
	else 
	{
		a -> father = getori(a -> father);//顺带直接将a的父节点置为祖先
		return a -> father;
	}
}

bool isconnect(node * a, node * b)//判断两节点是否连通
{
	return getori(a) == getori(b);
}

void connect(node * a, node * b)//连接 相当于并查集的并
{
	if (a -> father == NULL) a -> father = b;
	else a -> father -> father = b;//一开始在这里WA了= =
	return;
}

int main()
{
	int poisum = 0, rotsum = 0;
	int src = 0, dest = 0, lenth = 0;
	node* poi;

	while (true)
	{
		scanf("%d", &poisum);
		if (!poisum) break;//点数为0直接退出

		priority_queue <rot> pq;//用优先队列进行排序
		poi = new node[poisum + 2];

		scanf("%d", &rotsum);
		for (int i = 0; i < rotsum; ++i)
		{
			scanf("%d%d%d", &src, &dest, &lenth);
			pq.push(rot(src, dest, lenth));
		}

		int usedrot = 0, totallen = 0;
		while(usedrot < poisum  - 1)//由最小生成树 边数一定为点数减一
		{
			rot r_temp = pq.top();//优先队列top的一定为最短的路径
			if(!isconnect(&poi[r_temp.sr], &poi[r_temp.de]))//判是否已经连通
			{
				totallen += r_temp.len;
				++usedrot;
				connect(&poi[r_temp.sr], &poi[r_temp.de]);
			}
			pq.pop();
		}
		printf("%d\n", totallen);
		delete poi;

	}
	return 0;
}

你可能感兴趣的:(poj)