poj 1273 Drainage Ditches

第一道网络流, edmonds_karp
一开始,自己写了一个,能找到的所有数据都过了,可就是一直WA。
然后,就找了个模板。

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 53435 Accepted: 20363

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

/*
 * @author [email protected]
 * 
 */
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <queue>
#define maxn 210
#define inf 1000000000
using namespace std;

int n = 0, m = 0;
int cap[maxn][maxn] = {0};

int edmonds_karp(int src, int dest)
{
	int flow_sum = 0;
	int cur_flow[maxn] = {0};
	int prev[maxn] = {0};
	queue<int> q;

	while(true)
	{
		memset(cur_flow, 0, sizeof(cur_flow));

		cur_flow[src] = inf;
		q.push(src);
		while(!q.empty())
		{
			int cur = q.front();
			q.pop();
			for (int i = 1; i <= n; ++i)
			{
				if (!cur_flow[i] && cap[cur][i] > 0)
				{
					q.push(i);
					if (cur_flow[cur] > cap[cur][i])
						cur_flow[i] = cap[cur][i];
					else
						cur_flow[i] = cur_flow[cur];
					prev[i] = cur;
				}
			}
		}

		if (cur_flow[dest] == 0)
			break;
		for (int i = dest; i != src; i = prev[i])
		{
			cap[prev[i]][i] -= cur_flow[dest];
			cap[i][prev[i]] += cur_flow[dest];
		}
		flow_sum += cur_flow[dest];

	}
	return flow_sum;
}

int main()
{
	int s = 0, d = 0, c = 0;
	while(scanf("%d%d", &m, &n) != EOF)
	{
		memset(cap, 0, sizeof(cap));

		for (int i = 0; i < m; ++i)
		{
			scanf("%d%d%d", &s, &d, &c);
			cap[s][d] += c;
		}
		printf("%d\n", edmonds_karp(1, n));
	}
	return 0;
}




你可能感兴趣的:(poj,cpp)