7_7_2013 B.Arithmetic Progression

Problem B: Arithmetic Progression

Time Limit: 1 Sec   Memory Limit: 32 MB
Submit: 55   Solved: 25
[ Submit][ Status][ Web Board]

Description

“In mathematics, an arithmetic progression (AP) or arithmetic sequence is a sequence of numbers such that the difference between the consecutive terms is constant. For instance, the sequence 5, 7, 9, 11, 13, … is an arithmetic progression with common difference of 2.”

Wikipedia

This is a quite simple problem, give you the sequence, you are supposed to find the length of the longest consecutive subsequence which is an arithmetic progression.

Input

There are several test cases. For each case there are two lines. The first line contains an integer number N (1 <= N <= 100000) indicating the number of the sequence. The following line describes the N integer numbers indicating the sequence, each number will fit in a 32bit signed integer.

Output

For each case, please output the answer in one line.

Sample Input

1 4 7 9 11 14

Sample Output

3

#include <iostream>
#include <stdio.h>
using namespace std;

int
main()
{
    //freopen("ap.out", "w", stdout);
    int n, num, maxnum;
    int a, b, c, d;
    while(cin>>n){
        cin>>a>>b;
        num=2;
        maxnum=0;
        for(int i=3; i<=n; i++){
            cin>>c;
            if(c-b==b-a){
                num++;
                if(num>maxnum)maxnum=num;
            }
            else{
                num=2;
            }
            a=b;
            b=c;
        }
        cout<<maxnum<<endl;
    }
    return 0;

}
最長等差數列

你可能感兴趣的:(7_7_2013 B.Arithmetic Progression)