7_12_2013 F: Help Johnny

Problem F: Help Johnny

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 100   Solved: 42
[ Submit][ Status][ Web Board]

Description

Poor Johnny is so busy this term. His tutor threw lots of hard problems to him and demanded him to 
accomplish those problems in a month. What a wicked tutor! After cursing his tutor thousands of times, 
Johnny realized that he must start his work immediately.  
The very problem Johnny should solve firstly is about a strange machine called Warmouth. In the Warmouth 
there are many pairs of balls. Each pair consists of a red ball and a blue ball and each ball is assigned a value. 
We can represent a pair in the form of (R, B) in which R is the value of the red ball and B is of the blue one. 
Warmouth has a generator to calculate the match value of two pairs. The match value of (R1, B1) and (R2, 
B2) is R1*B2+R2*B1. Initially, Warmouth is empty. Pairs are sent into Warmouth in order. Once a new pair 
comes, it will be taken into the generator with all the pairs already in Warmouth.  
Johnny’s work is to tell his tutor the sum of all match values given the list of pairs in order. As the best 
friend of Johnny, would you like to help him? 

Input

The first line of the input is T (no more than 10), which stands for the number of lists Johnny received.  
Each list begins with “N“(without quotes). N is the number of pairs of this list and is no more than 100000. 
The next line gives N pairs in chronological order. The 2i-th number is the value of the red ball of the i-th 
pair and the (2i+1)-th number is the value of the blue ball of the i-th pair. The numbers are positive integers 
and smaller than 100000. 

Output

Please output the result in a single line for each list.  

Sample Input

2

 3 

 1 3 2 2 3 1 

 2

 4 5 6 7

Sample Output

26 

 58

#include <stdio.h>
#include <iostream>
using namespace std;

int
main()
{
    //freopen("help.in", "r", stdin);
    //freopen("HELP.out", "w", stdout);
    int n, tu, a[100010], b[100010];
    long long int sum, sa, sb;
    cin>>tu;
    while(tu--){
        sum=sa=sb=0;
        cin>>n;
        for(int i=0; i<n; i++){
            cin>>a[i]>>b[i];
            sa+=a[i];
            sb+=b[i];
        }
        for(int i=0; i<n; i++){
            sum+=a[i]*(sb-b[i])+b[i]*(sa-a[i]);
        }
        cout<<sum/2<<endl;
    }
    return 0;
}


你可能感兴趣的:(7_12_2013 F: Help Johnny)